Bug 137001 - streaming playback failure pops up two dialogs
Summary: streaming playback failure pops up two dialogs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-25 02:45 UTC by Dan Williams
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-26 17:43:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Williams 2004-10-25 02:45:11 UTC
When you click on a stream that can't be connected to, you get two
dialogs:

1) "Could not open vfs file "http://66.135.33.226:8000/" for reading."
2) "Could not pause playback"

I certainly didn't try to pause playback, so I'm not quite sure what
the second dialog is talking about...

Comment 1 Ziga Mahkovec 2005-04-23 18:41:27 UTC
Still seeing this in FC4T2 (rhythmbox-0.8.8-2).  It's actually worse now, since
GNOME 2.10 won't focus the popups when you switch to a another workspace, so a
double-enter-bang no longer gets rid of the popups.

There are also other usability issues with streaming playlists (let me know if I
should move these to a separate entry):

- The user interface will freeze while connecting to a stream (which can
sometimes take several seconds).

- New streams are not immediately saved to disk (seems they're only saved upon
exit).  In the unfortunate event of a crash, new streams are lost.

- The currently playing file or stream will immediately stop when selecting a
new stream.  Ideally, it should not stop until actually connected to the new
stream (and not stop at all should the connection fail).


Comment 2 Matthias Clasen 2006-11-26 17:43:47 UTC
There are definitively still issues with unreachable streams, but this
particular problem seems to be fixed in current FC6/FC7 versions of rhythmbox.


Note You need to log in before you can comment on or make changes to this bug.