Bug 1370053 - fix EXPECT_WITHIN
Summary: fix EXPECT_WITHIN
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-25 07:58 UTC by Anuradha
Modified: 2017-03-27 18:22 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 18:22:15 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Anuradha 2016-08-25 07:58:14 UTC
Description of problem:

EXPECT_WITHIN did string match in one place and regex in other. Leading to incorrect looping in many testcase. Fix it.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2016-08-25 08:01:11 UTC
REVIEW: http://review.gluster.org/15315 (tests: fix EXPECT_WITHIN) posted (#1) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 2 Worker Ant 2016-08-26 12:16:27 UTC
REVIEW: http://review.gluster.org/15315 (tests: fix EXPECT_WITHIN) posted (#2) for review on master by Anuradha Talur (atalur@redhat.com)

Comment 3 Worker Ant 2016-08-29 20:45:21 UTC
REVIEW: http://review.gluster.org/15315 (tests: fix EXPECT_WITHIN) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 4 Worker Ant 2016-08-29 20:45:24 UTC
REVIEW: http://review.gluster.org/15341 (tests: Fix spurious failure of ec-root-heal.t) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 5 Worker Ant 2016-08-29 23:05:30 UTC
REVIEW: http://review.gluster.org/15341 (tests: Fix spurious failures because of wrong shd up function) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 6 Worker Ant 2016-08-29 23:05:33 UTC
REVIEW: http://review.gluster.org/15315 (tests: fix EXPECT_WITHIN) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 7 Worker Ant 2016-08-31 18:01:44 UTC
COMMIT: http://review.gluster.org/15341 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 63d24908e01b24cc21bea584fed4b719fca865f3
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Tue Aug 30 02:02:45 2016 +0530

    tests: Fix spurious failures because of wrong shd up function
    
    Fixed the way shd up check is done to prevent self-heal daemon
    not running error when heal full command is executed.
    
    Change-Id: I93c4a0da12316373d62cd4ea74432cd9bf2b090c
    BUG: 1370053
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/15341
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Anuradha Talur <atalur@redhat.com>

Comment 10 Shyamsundar 2017-03-27 18:22:15 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.