Bug 1370116 - Tests : Adding a test to check for inode leak
Summary: Tests : Adding a test to check for inode leak
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-25 11:04 UTC by Mohamed Ashiq
Modified: 2018-03-15 11:16 UTC (History)
2 users (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-15 11:16:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohamed Ashiq 2016-08-25 11:04:42 UTC
Description of problem:
Add Test that checks if there is an inode leak from statedump.

Comment 1 Worker Ant 2016-08-25 11:26:13 UTC
REVIEW: http://review.gluster.org/15318 (tests : add a test to check if there is an inode leak) posted (#1) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

Comment 2 Worker Ant 2016-08-25 12:56:03 UTC
REVIEW: http://review.gluster.org/15318 (tests : add a test to check if there is an inode leak) posted (#2) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

Comment 3 Worker Ant 2016-08-25 14:26:05 UTC
REVIEW: http://review.gluster.org/15318 (tests : add a test to check if there is an inode leak) posted (#3) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

Comment 4 Worker Ant 2016-08-25 18:00:10 UTC
REVIEW: http://review.gluster.org/15318 (tests : add a test to check if there is an inode leak) posted (#4) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

Comment 5 Worker Ant 2016-08-30 06:54:13 UTC
REVIEW: http://review.gluster.org/15318 (tests : add a test to check if there is an inode leak) posted (#5) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

Comment 6 Worker Ant 2016-08-31 06:45:02 UTC
REVIEW: http://review.gluster.org/15318 (tests : add a test to check if there is an inode leak) posted (#6) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

Comment 7 Worker Ant 2016-09-02 09:22:42 UTC
REVIEW: http://review.gluster.org/15318 (tests : add a test to check if there is an inode leak) posted (#7) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

Comment 8 Worker Ant 2016-09-06 06:12:57 UTC
REVIEW: http://review.gluster.org/15318 (tests : add a test to check if there is an inode leak) posted (#8) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)

Comment 9 Worker Ant 2017-11-22 14:42:35 UTC
COMMIT: https://review.gluster.org/15318 committed in master by \"Mohamed Ashiq Liyazudeen\" <mliyazud@redhat.com> with a commit message- tests : add a test to check if there is an inode leak

This test check if there is inode leak in bricks.

lru_size for mount is expected to be zero. active_size for mount
is expected to be 1 which is of root.

Change-Id: I18762b4255af411f1b55c0be98451c8ef1b35478
BUG: 1370116
Signed-off-by: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>

Comment 11 Shyamsundar 2018-03-15 11:16:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.