Bug 1370118 - Some fonts are missing on the netinst and dvd
Summary: Some fonts are missing on the netinst and dvd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1369329 1369333 1369341 (view as bug list)
Depends On:
Blocks: F25FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-08-25 11:18 UTC by Petr Schindler
Modified: 2016-10-26 22:31 UTC (History)
12 users (show)

Fixed In Version: lorax-25.17-1 lorax-25.17-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-26 22:31:19 UTC


Attachments (Terms of Use)
missing fonts in language selection (109.53 KB, image/png)
2016-08-25 11:19 UTC, Petr Schindler
no flags Details
Missing fonts in time and date (91.43 KB, image/png)
2016-08-25 11:20 UTC, Petr Schindler
no flags Details

Description Petr Schindler 2016-08-25 11:18:42 UTC
Description of problem:
On the page with language selection there are missing fonts for Tibetan, Khmer and Burmese. This happens only on netinst and dvd. Lives have fonts. There are only utf characters visible (please see the attachment).

There aren't many things translated in those languages, but for example in time and date user can't properly set time zone because of this bug (see second attachment).

Version-Release number of selected component (if applicable):
anaconda-25.20-1
Fedora-Server-dvd-x86_64-25-Alpha-1.2.iso

How reproducible:
always

Additional info:
I propose this as final blocker as it violates the criterion: "The installer must correctly display all sufficiently complete translations available for use."

Comment 1 Petr Schindler 2016-08-25 11:19:51 UTC
Created attachment 1193984 [details]
missing fonts in language selection

Comment 2 Petr Schindler 2016-08-25 11:20:29 UTC
Created attachment 1193985 [details]
Missing fonts in time and date

Comment 3 Geoffrey Marr 2016-08-29 19:48:52 UTC
Discussed during the 2016-08-29 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made because it is a clear violation of the following Final Blocker critiera:

"The installer must correctly display all sufficiently complete translations available for use."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-08-29/f25-blocker-review.2016-08-29-16.00.txt

Comment 4 Samantha N. Bueno 2016-10-14 20:47:47 UTC
*** Bug 1369341 has been marked as a duplicate of this bug. ***

Comment 5 Samantha N. Bueno 2016-10-14 20:48:16 UTC
*** Bug 1369333 has been marked as a duplicate of this bug. ***

Comment 6 Samantha N. Bueno 2016-10-14 20:48:47 UTC
*** Bug 1369329 has been marked as a duplicate of this bug. ***

Comment 7 Vendula Poncova 2016-10-17 13:28:47 UTC
https://github.com/rhinstaller/lorax/pull/167/

Comment 8 Fedora Update System 2016-10-19 08:29:30 UTC
lorax-25.17-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a0a45fcbe

Comment 9 Adam Williamson 2016-10-25 18:11:30 UTC
Fix looks good to me, built an installer image to test, no more unicode boxes on the language selection screen.

Comment 10 Fedora Update System 2016-10-26 22:31:19 UTC
lorax-25.17-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.