Bug 137012 - [patch]Bengali does not have fallback fonts
Summary: [patch]Bengali does not have fallback fonts
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: Indic 137149 138056
TreeView+ depends on / blocked
 
Reported: 2004-10-25 05:45 UTC by Leon Ho
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: openoffice.org-i18n-1.1.2-18.6.EL4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-16 06:34:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first patch to map bn_IN to "BENGALI" (944 bytes, patch)
2004-12-08 15:07 UTC, Caolan McNamara
no flags Details | Diff
second patch to classify BENGALI as a CTL language (620 bytes, patch)
2004-12-08 15:12 UTC, Caolan McNamara
no flags Details | Diff
third patch to add bengali to i18npool (5.75 KB, patch)
2004-12-08 15:19 UTC, Caolan McNamara
no flags Details | Diff

Description Leon Ho 2004-10-25 05:45:40 UTC
Description of problem:
Bengali still has not got the fallback font when doing
LANG=bn_IN.UTF-8 oowriter. VCL.xcu does have entries for the lang

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. LANG=bn_IN.UTF-8 oowriter
2. Look at the default font selection

  
Actual results:
Nimbus Roman No9 L

Expected results:
Lohit Bengali

Additional info:
Compare these to other indic languages like LANG=hi_IN.UTF-8

Comment 1 Dan Williams 2004-11-15 14:33:04 UTC
Nov 22 is the probable target date for starting work on this.

Comment 2 Lawrence Lim 2004-11-30 07:06:04 UTC
Checked the font for CJK and Indic locales. Only bn_IN does not have
the proper fallback fonts.

Tested with openoffice.org-1.1.2-14.6.EL4.

Comment 3 Caolan McNamara 2004-12-08 15:07:57 UTC
Created attachment 108112 [details]
first patch to map bn_IN to "BENGALI"

1. patch to tools maps bn_IN (instead of bn_BD) to "LANGUAGE_BENGALI" like 2.0
does

Comment 4 Caolan McNamara 2004-12-08 15:12:32 UTC
Created attachment 108113 [details]
second patch to classify BENGALI as a CTL language

2. patch to svtools to classify BENGALI as a CTL language. Otherwise the
default will be the western font entries when in the bengali locale, even
though the CTL entries will be correctly set

Comment 5 Caolan McNamara 2004-12-08 15:19:28 UTC
Created attachment 108114 [details]
third patch to add bengali to i18npool

3. patch to i18npool to add a bengali entry like the other hindi varients. Not
100% sure that this is required. Followed the minimal mr_IN varient to create
it.

Comment 6 Caolan McNamara 2004-12-08 15:23:52 UTC
Those should do the trick, works for me (tm). Though its an open
question if the patches need to be duplicated to handle Bangladeshi
Bengali
i.e. add
1. { LANGUAGE_BENGALI_BANGLADESH,          "bn", "BD" }, 
to isolang.cxx
and
2. #define LANGUAGE_BENGALI_BANGLADESH         0x0845
to tools/inc/lang.hxx
3. add LANGUAGE_BENGALI_BANGLADESH to the svtools classification thing
4. (required ?) stick an appropiate xml and matching makefile.mk
changes ala patch 3 above for bn-BD.xml

Comment 8 Dan Williams 2004-12-09 02:11:04 UTC
Patches should be in 1.1.2-16 and later

Comment 9 Akira TAGOH 2004-12-10 17:03:27 UTC
Tested with 1.1.2-17.6.EL4. the proper font is chosen by default on
all CJK and 5 Indic locales

Comment 10 Lawrence Lim 2004-12-16 06:34:05 UTC
Confirmed fixed in openoffice.org-i18n-1.1.2-18.6.EL4. OOo in bn_IN
can now type mix en and bn_IN characters in a document.


Thanks.


Note You need to log in before you can comment on or make changes to this bug.