Bug 1370129 - PV recycler image fails to start
Summary: PV recycler image fails to start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Bradley Childs
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-25 11:44 UTC by Tomas Schlosser
Modified: 2016-09-27 09:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:46:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Tomas Schlosser 2016-08-25 11:44:01 UTC
Description of problem:
When PVC is deleted, the PV is not recycled and ends up in 'Failed' state.

Version-Release number of selected component (if applicable):
atomic-openshift-3.3.0.23-1.git.0.f3689d5.el7.x86_64
image - openshift3/ose-recycler:v3.3.0.23

Steps to Reproduce:
1. create PVC (you can use 'oc new-app --template=mysql-persistent)
2. let it bind to PV
3. delete PVC (oc delete pvc mysql)

Actual results:
PV ends up in failed state and recycler pod is stuck in openshift-infra project.

Expected results:
PV is scrubbed and returned to the pool.

Additional info:
Upon deletion, recycler pod is created, but fails:
recycler-for-vol08     0/1       RunContainerError   0          12s

Upon further investigation, there is a binary missing apparently:
recycler-for-vol08   Pod       spec.containers{pv-recycler}   Warning   Failed    {kubelet node1.devel.xpaas}   Failed to start container with docker id b3a4a676947c with error: Error response from daemon: Container command not found or does not exist.

Running it through docker says the same thing:
$ docker run --rm openshift3/ose-recycler:v3.3.0.23
exec: "/usr/bin/openshift-recycle": stat /usr/bin/openshift-recycle: no such file or directory
docker: Error response from daemon: Container command not found or does not exist..

And listing everything in /usr/bin does not find any match for recycle:
$ docker run --rm --entrypoint=/usr/bin/ls openshift3/ose-recycler:v3.3.0.23 /usr/bin | grep recycle

In previous version (v3.2.1.13 - latest released), the binary was found, but it's name was just recycle, not openshift-recycle.

Comment 1 Eric Paris 2016-08-25 12:23:44 UTC
There was a problem with the builds until 3.3.0.25 where the recycle container was not being properly created. This is resolved.

Comment 2 Tomas Schlosser 2016-08-25 12:37:03 UTC
Thanks for looking into this! I have verified that the new image works and PVs are scrubbed and available as expected.

Comment 4 errata-xmlrpc 2016-09-27 09:46:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.