Bug 1370227 - Filezilla crashes at startup on wayland
Summary: Filezilla crashes at startup on wayland
Keywords:
Status: CLOSED DUPLICATE of bug 1266743
Alias: None
Product: Fedora
Classification: Fedora
Component: filezilla
Version: 25
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Nicolas Chauvet (kwizart)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-25 16:08 UTC by Heiko Adams
Modified: 2016-09-14 00:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-14 00:25:31 UTC


Attachments (Terms of Use)

Description Heiko Adams 2016-08-25 16:08:34 UTC
Description of problem:
When starting filezilla on a wayland session it crashes with following error:
$ filezilla
Reading locale option from /home/heiko/.filezilla/filezilla.xml

(filezilla:18497): GLib-GObject-WARNING **: invalid cast from 'GdkWaylandDisplay' to 'GdkX11Display'
Segmentation fault (Speicherabzug geschrieben)

Version-Release number of selected component (if applicable):
$ rpm -q filezilla
filezilla-3.21.0-1.fc25.x86_64

How reproducible:
allways

Steps to Reproduce:
1. Log into a wayland session
2. Start filezilla
3.

Actual results:
filezilla crashes on startup

Expected results:
filezilla should start

Additional info:

Comment 1 Scott Talbert 2016-09-03 01:03:40 UTC
Can you please provide a stacktrace?  This may be a duplicate of:
https://bugzilla.redhat.com/show_bug.cgi?id=1266743

Comment 2 Scott Talbert 2016-09-14 00:25:31 UTC

*** This bug has been marked as a duplicate of bug 1266743 ***


Note You need to log in before you can comment on or make changes to this bug.