Bug 137023 - ccsd should have local-only non-clustered mode
ccsd should have local-only non-clustered mode
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: ccs (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Earl Brassow
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-25 04:32 EDT by David Teigland
Modified: 2009-04-16 16:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 16:00:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Teigland 2004-10-25 04:32:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
Often it would be extremely useful if ccsd could be run with
a flag telling it to just use the local cluster.conf file
and completely ignore clustering.  I suspect this would be
invaluable for users and support trying to diagnose and work
around problems as well.  Any failure by ccs to work with
magma or magma with cluster/lock manager leaves you stuck
with next to no options or error messages to work with.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. none
2.
3.
    

Additional info:
Comment 1 Kiersten (Kerri) Anderson 2004-11-04 10:07:51 EST
Updates with the proper version and component name.
Comment 2 Kiersten (Kerri) Anderson 2004-11-04 10:16:36 EST
Updates with the proper version and component name.
Comment 3 Kiersten (Kerri) Anderson 2004-11-04 10:20:57 EST
Updates with the proper version and component name. Again, just love out tools.
Comment 4 Kiersten (Kerri) Anderson 2004-11-16 14:09:18 EST
Updating version to the right level in the defects.  Sorry for the storm.
Comment 5 Jonathan Earl Brassow 2005-01-04 16:28:09 EST
The error messages now printed out will tell the user if there is a
problem with magma.

I think trying to tell the user what is wrong when something happens
is better than giving the user ways hunt down a problem.

Perhaps there is merit in this request, but I think some of the
confusion that originally prompted this bug report has been resolved
by other means.
Comment 6 David Teigland 2005-03-11 04:52:30 EST
I think the real problem here is that if anything goes wrong with
ccs/magma (which tends to be quite often), a person is completely
dead in the water -- there's no work-around possible.  Telling
a person what's wrong doesn't help at all if they don't know how
to fix it or work around it.

Take me and my present situation as an example of an average user.
I'm sure it's my fault for doing some little thing wrong somewhere.
I just compiled and installed everything. I ran ccsd and I got this:

Failed to connect to cluster manager.
Hint: Magma plugins are not in the right spot.

OK, hm.  What should I do next?  I seem to remember hearing something
about using "magma_tool" to resolve this... magma_tool -h...
not sure, maybe "list"?  OK, that shows what might be a problem:
"Magma: Checking plugins in /root/cluster/build/usr/lib/magma"
I really doubt that ccsd is going to be able to find anything in
/root.  Why did it get there and what can I do about it?  Not sure,
so ask someone else who might have some experience (pjc) -- suggests
using configure --prefix=/usr.  OK, rerun configure with that,
then "make install".  Try again, nothing different.  OK, last
resort -- make distclean, configure, make, make install.  Try again.
Same thing.

I've wasted a lot of time at this point and really wish I could just
start up ccsd and tell it to use /etc/cluster/cluster.conf since I'm
just trying to do a quick check on something else...

What if a customer was in a similar position and really needed to
force this to work quickly?  This little feature could make a huge
difference -- I know it would have helped me out on many, many
occasions.

So, please reconsider and at a minimum keep it in the list of
features that would be _really_ helpful.
Comment 7 Jonathan Earl Brassow 2005-11-21 16:18:41 EST
Dave, is this still something you want?  I let you check in your changes to
'HEAD', have you migrated them to the other branches?

Note You need to log in before you can comment on or make changes to this bug.