Bug 137025 - missing return statement
missing return statement
Product: Fedora
Classification: Fedora
Component: joe (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Depends On:
  Show dependency treegraph
Reported: 2004-10-25 04:47 EDT by David Binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-01-27 04:28:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Binderman 2004-10-25 04:47:35 EDT
Description of problem:

I just tried to compile package joe-3.1-4 from 
Redhat Fedora Core 3 Test 3.

The compiler said

uedit.c(122): warning #1011: missing return statement at end of
non-void function "u_goto_left"

Upon inspection of the source code, I think there is a missing return
statement at the end of the routine.

What happens if bw->o.picture is true, but bw->cursor->xcol is false ?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Ivana Varekova 2005-01-24 05:47:50 EST
Thank you for your notice.
The problem was fixed.
Ivana Varekova
Comment 2 Ivana Varekova 2005-01-27 04:28:34 EST
Solved with 3.1-7.

Note You need to log in before you can comment on or make changes to this bug.