Bug 137025 - missing return statement
Summary: missing return statement
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: joe   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-25 08:47 UTC by David Binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 09:28:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Binderman 2004-10-25 08:47:35 UTC
Description of problem:

I just tried to compile package joe-3.1-4 from 
Redhat Fedora Core 3 Test 3.

The compiler said

uedit.c(122): warning #1011: missing return statement at end of
non-void function "u_goto_left"

Upon inspection of the source code, I think there is a missing return
statement at the end of the routine.

What happens if bw->o.picture is true, but bw->cursor->xcol is false ?



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ivana Varekova 2005-01-24 10:47:50 UTC
Thank you for your notice.
The problem was fixed.
Ivana Varekova

Comment 2 Ivana Varekova 2005-01-27 09:28:34 UTC
Solved with 3.1-7.


Note You need to log in before you can comment on or make changes to this bug.