Bug 1370260 - auto expansion of ceph clusters should never include floppy devices
Summary: auto expansion of ceph clusters should never include floppy devices
Keywords:
Status: CLOSED EOL
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: core
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3
Assignee: Nishanth Thomas
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-25 18:25 UTC by Jeff Applewhite
Modified: 2018-11-19 05:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-19 05:42:59 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jeff Applewhite 2016-08-25 18:25:36 UTC
Description of problem:
when installing ceph floppy devices get detected and potentially can be used for journals or osds on expansion too

Version-Release number of selected component (if applicable):

2.0 

How reproducible:
uncertain

Steps to Reproduce:
1.install ceph on a piece of hardware with a floppy device inserted (or a virtual fd)
2. expand the cluster with a node having a floppy device or two
3.

Actual results:
fd gets used as a valid device

Expected results:
floppies are never considered or used for expansion 

Additional info:

I also create BZ BZ1370257 to address the ceph installer using floppy devices as well. this BZ is targeted at expansion only

Comment 3 Shubhendu Tripathi 2018-11-19 05:42:59 UTC
This product is EOL now


Note You need to log in before you can comment on or make changes to this bug.