Bug 137036 - No non-en manpages. broken conversion of uk hints.
No non-en manpages. broken conversion of uk hints.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-25 10:12 EDT by Andy Shevchenko
Modified: 2013-07-02 19:03 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.6.1-0.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 07:12:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for utf8fying mc's itself documentation (help) (1.37 KB, patch)
2004-10-25 10:13 EDT, Andy Shevchenko
no flags Details | Diff
patch of spec file for dropping other problems (%makeinstall seems to be broken) (1.95 KB, patch)
2004-10-25 10:17 EDT, Andy Shevchenko
no flags Details | Diff
spec file patch for add russian and ukrainian help conversation (585 bytes, patch)
2004-12-07 06:02 EST, Andy Shevchenko
no flags Details | Diff

  None (edit)
Description Andy Shevchenko 2004-10-25 10:12:22 EDT
Description of problem:
1. In non-utf locale mc is not correctly displaing its own help. 
Every non-us-ascii chars are not visibled.
2. Install method in the spec does not put the non-english man pages 
that are formed by make in doc subdir.
3. In prep section of spec the ukrainian hints is converting from 
KOI8-R. Must be KOI8-U.


Version-Release number of selected component (if applicable):
Version:        4.6.1
Release:        0.8
Epoch:          1

How reproducible:
Just try to hit F1 in the working mc.

Additional info:
See attached patches for dropping the problem.
Comment 1 Andy Shevchenko 2004-10-25 10:13:51 EDT
Created attachment 105722 [details]
Patch for utf8fying mc's itself documentation (help)
Comment 2 Andy Shevchenko 2004-10-25 10:17:32 EDT
Created attachment 105723 [details]
patch of spec file for dropping other problems (%makeinstall seems to be broken)
Comment 3 Leonard den Ottolander 2004-10-25 12:52:30 EDT
Jindrich, I don't think you should apply the patch in comment 1. I
contacted Vladimir Nadvornik about this and he's working on this. This
patch differs from the approach in the other UTF-8 patches. I think
using an mbstrlen in the appropriate place is more conforming to the
used code style in the other parts.

This bug is a duplicate of bug 136826. Closing.


*** This bug has been marked as a duplicate of 136826 ***
Comment 4 Leonard den Ottolander 2004-10-25 13:06:38 EDT
As this report is actually about three issues I'll reopen it. Next
time please first check bugzilla, and file different reports for
different issues. The help issue is already in bugzilla as you can
see, so you should have opened two bug reports, one about the man page
issue and one about the conversion issue.
Comment 5 Leonard den Ottolander 2004-10-25 14:58:03 EDT
Further discussion of UTF-8 issues with help under bug 136826.
Comment 6 Jindrich Novy 2004-10-27 10:16:43 EDT
Andy, I switched encoding from koi8-r to koi8-u in case of Ukranian
hints and added non-en man pages. Thanks for the report.

Jindrich
Comment 7 Andy Shevchenko 2004-11-04 06:45:16 EST
Thank you.

All will be seen to be ok, except polish man pages that contains mc.1.

Name: man-pages-pl
Version: 0.23
Release: 2

Comment 8 Jindrich Novy 2004-11-08 07:53:12 EST
Fixed in mc-4.6.1-0.9.
Comment 9 Andy Shevchenko 2004-12-07 06:00:10 EST
Missed tussian and ukrainian conversation of manuals and help files 
in 
Version:        4.6.1
Release:        0.11FC3
Epoch:          1
from freshen updates of FC3.

Applied patch in attachment.
Comment 10 Andy Shevchenko 2004-12-07 06:02:19 EST
Created attachment 108030 [details]
spec file patch for add russian and ukrainian help conversation
Comment 11 Jindrich Novy 2004-12-07 08:10:58 EST
Fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.