Bug 1370512 - Received ACIError instead of DuplicatedError in stageuser_tests
Summary: Received ACIError instead of DuplicatedError in stageuser_tests
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-26 14:12 UTC by Petr Vobornik
Modified: 2016-11-04 06:02 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 06:02:17 UTC


Attachments (Terms of Use)
console.log (7.26 KB, text/plain)
2016-09-19 11:45 UTC, Abhijeet Kasurde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Petr Vobornik 2016-08-26 14:12:36 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/6199

We do not have right to write to users delete_container. In case that
user already exists in that container and we tried to add entry, we
receive ACIError. This must be checked and DuplicationEntry error must
be raised before.


Several similar errors in ipa.test_xmlrpc.test_stageuser_plugin:
{{{
        except errors.PublicError as got_exception:
>           assert type(expected_exception) is type(got_exception)
E           assert <class 'ipalib.errors.DuplicateEntry'> is <class 'ipalib.errors.ACIError'>
E            +  where <class 'ipalib.errors.DuplicateEntry'> = type(DuplicateEntry(u'user with name "tuser" already exists',))
E            +  and   <class 'ipalib.errors.ACIError'> = type(ACIError(u"Insufficient access: Insufficient 'add' privilege to add the entry ...ts,cn=provisioning,dc=dom-150,dc=idm,dc=lab,dc=eng,dc=brq,dc=redhat,dc=com'.",))
}}}

Version of DS: 389-ds-base-1.3.5.12-1.fc24.x86_64

In the latest provided build of DS, there were some changes in ACI enforcing, thus this is probbably the root cause

Comment 2 Jan Cholasta 2016-08-30 06:22:51 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/5c50b265e6b5a0d06f213b5eb581c96e3392aeea

Comment 5 Martin Bašti 2016-09-19 11:18:24 UTC
Steps to reproduce:

$ ipa user-add test
$ ipa user-del test --preserve
$ ipa user-add test

Comment 6 Abhijeet Kasurde 2016-09-19 11:45:13 UTC
Verified using IPA version ::
ipa-server-4.4.0-12.el7.x86_64


Marking BZ as verified.

Comment 7 Abhijeet Kasurde 2016-09-19 11:45 UTC
Created attachment 1202455 [details]
console.log

Comment 9 errata-xmlrpc 2016-11-04 06:02:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.