Bug 1370623 - subscription-manager-gui Manage repositories not sorting
Summary: subscription-manager-gui Manage repositories not sorting
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: Jan Stavel
URL:
Whiteboard:
: 1378927 1380725 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-26 20:07 UTC by Marek Haicman
Modified: 2017-08-01 19:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:20:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
Can be sorted by Modified (205.81 KB, image/png)
2017-04-05 08:38 UTC, Shwetha Kallesh
no flags Details
Sorted by repo id (208.94 KB, image/png)
2017-04-05 08:38 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Github RedHatQE rhsm-qe pull 601 None None None 2016-10-19 16:21:23 UTC
Github RedHatQE rhsm-qe pull 609 None None None 2016-10-17 10:03:40 UTC
Github RedHatQE rhsm-qe pull 610 None None None 2016-10-19 16:20:28 UTC
Github candlepin subscription-manager pull 1477 None None None 2016-09-06 13:15:42 UTC
Red Hat Bugzilla 1378927 None None None Never
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Internal Links: 1378927

Description Marek Haicman 2016-08-26 20:07:50 UTC
Description of problem:
In "Manage Repositories" dialog, the only column where sorting works is "Modified" - "Enabled" and "Gpgcheck" are not activable, and Repository is activable, but does not produce any change, and the lines stays disordered.

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.17.11-1.el7.x86_64
subscription-manager-1.17.11-1.el7.x86_64

How reproducible:
reliably

Steps to Reproduce:
1. subscription-manager-gui
2. open Repositories Management windows
3. try to sort by different columns

Actual results:
Enabled - is not clickable
Gpgcheck - is not clickable
Repository - is clickable, but has no effect on the item order
Modified - works

Expected results:
Enabled - Works
Gpgcheck - Works
Repository - Works
Modified - works

Additional info:

Comment 2 Jan Stavel 2016-09-19 09:43:23 UTC
I have added gui test for this behaviour.
See external trackers.

Comment 3 Kevin Howell 2016-09-28 15:15:24 UTC
*** Bug 1378927 has been marked as a duplicate of this bug. ***

Comment 4 Kevin Howell 2016-10-10 18:18:31 UTC
*** Bug 1380725 has been marked as a duplicate of this bug. ***

Comment 6 Shwetha Kallesh 2017-04-05 08:38:27 UTC
Created attachment 1268885 [details]
Can be sorted by Modified

Comment 7 Shwetha Kallesh 2017-04-05 08:38:58 UTC
Created attachment 1268886 [details]
Sorted by repo id

Comment 8 Kevin Howell 2017-04-05 13:48:09 UTC
The fix that went in for this in the PR addressed an issue where columns that should have been sorting were not. Sorting additional columns would be a new feature request, (please open an RFE for that if desired).

So as of this bug fix:

Expected results:
Enabled - Not clickable
Gpgcheck - Not clickable
Repository - Sortable
Modified - Sortable

Comment 9 Marek Haicman 2017-04-05 18:41:31 UTC
For posterity - Repository column was the important one to me, so I'm ok with the resolution.

Comment 10 Shwetha Kallesh 2017-04-06 07:58:18 UTC
marking bug as verified!!

[root@dhcp70-137 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7

Comment 11 errata-xmlrpc 2017-08-01 19:20:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.