Bug 137064 - Upgrades of systems fail when selinux-policy-targeted is installed
Upgrades of systems fail when selinux-policy-targeted is installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
: SELinux
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-10-25 13:04 EDT by Elliot Lee
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 10:47:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliot Lee 2004-10-25 13:04:58 EDT
The %post script does load_policy of the old policy, because the
policy & file_contexts files don't get replaced.

Solution is s/(noreplace)// in the .spec file.
Comment 1 Colin Walters 2004-10-25 13:14:24 EDT
Just talked to Dan about this, the solution is to remove the bits from the
policy-targeted-sources postinst which does a make reload, which overwrites the
policy.18 and file_contexts files.

The idea is someone using selinux-policy-targeted-sources has to understand how
to do 'make reload'.
Comment 2 Daniel Walsh 2004-10-26 10:47:36 EDT
Fixed in selinux-policy-targeted-1.17.30.2.11

Note You need to log in before you can comment on or make changes to this bug.