Bug 137069 - Kick Start Error Messages Exception Occured, just after NFS mount
Kick Start Error Messages Exception Occured, just after NFS mount
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-25 13:33 EDT by Kirk Hagberg
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 08:54:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kirk Hagberg 2004-10-25 13:33:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
Kick Start install client is an IBM e325 server.  Boot from CD-R to 
start the install.  Client gets IP info from DHCP, then does an NFS 
mount (detailed in /var/log/messages on the Kick Start server).  Then 
the install dies with the following:

Kick Start Error Messages

            Exception Occured

Traceback ( most recent call Last ):
 
File "/usr/bin/anaconda", Line 1081, in ?

      intf.run (id, dispatch, configfileData)


File "/usr/lib/anaconda/text.py", Line 422, in run

(steps, args) = dispatch.currentStep ( )

 
File "/usr/lib/anaconda/dispatch.py", Line 262 in Current Step

Self.gotoNext ( )

 
File "/usr/lib/anaconda/dispatch.py", Line 157 in goto Next

Self.moveStep ( )





Version-Release number of selected component (if applicable):
kernel-2.4.21-20.ELsmp

How reproducible:
Always

Steps to Reproduce:
1.  Insert either AMD64 RHEWS2 Disc 1 or boot disk made from isolinux 
dir
2.  Type "linux ks=nfs:10.1.4.171:/home/kickstart/av64_install-
ks.cfg"  or just type av64_install as per isolinux.cfg
3.  Error message occurs
    

Actual Results:  Not possible

Expected Results:  Kick Start install started as detailed in 
av64_install-ks.cfg on Kick Start server

Additional info:
Comment 1 Jeremy Katz 2004-10-25 13:52:57 EDT
Please provide the complete traceback you received.
Comment 2 Kirk Hagberg 2004-10-25 15:53:14 EDT
rc = apply (func, self.bindArgs (args))

File "/usr/lib/anaconda/autopart.py", line 1337 in do AutoPartition
   do Partition ( diskset, Partitions, do Refresh = 0)

file "/usr/lib/anaconda/autopart.py", Line 990
   in do Partitioning ( ret, msg) =  ProcessPartitioning (diskset, 
requests, newparts )

File "/usr/lib/anaconda/autopart.py", Line 934,
  in process partioning ret = fit sized ( diskset, requests, 1, 
netparts )

File "/usr/lib/anaconda/autopart.py", Line 334,
  in fitsized disk = diskset.disks [drive]

Key Error :hda
/usr/lib/anaconda/autopat.py (334) fitsized( )
disk = diskset.disks [ drive ]
Comment 3 Jeremy Katz 2004-10-26 08:54:39 EDT
It looks like your kickstart config specifies the use of the disk
"hda" while your machine has no IDE disks (probably only SCSI disks,
eg, sda, instead).

Note You need to log in before you can comment on or make changes to this bug.