Bug 1371000 - Get error "TypeError: e.value.exclude is not a function" when clicking on Threads tab inside Threads console
Summary: Get error "TypeError: e.value.exclude is not a function" when clicking on Thr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Antonin Stefanutti
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-29 06:37 UTC by Xia Zhao
Modified: 2016-09-27 09:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:46:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screeshot of bug repro (159.87 KB, image/png)
2016-08-29 06:37 UTC, Xia Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC
Github openshift origin-web-console pull 501 None None None 2016-08-30 15:21:10 UTC
Github openshift origin pull 10722 None None None 2016-08-30 21:58:42 UTC

Description Xia Zhao 2016-08-29 06:37:36 UTC
Created attachment 1195183 [details]
Screeshot of bug repro

Description of problem:
Not able to get threads info inside Threads console, get error "TypeError: e.value.exclude is not a function" when clicking on Threads tab

Version-Release number of selected component (if applicable):
# openshift version
openshift v1.3.0-alpha.3+4250e53
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

How reproducible:
Always

Steps to Reproduce:
1. Login openshift
2. oc new-project test
3. oc new-app --docker-image=docker.io/chunyunchen/java-mainclass:2.3-SNAPSHOT
4. Visit JXM/Threads console after app pod is up

Actual results:
Not able to get threads info inside Threads console, get error "TypeError: e.value.exclude is not a function" when clicking on Threads tab

Expected results:
Should be able to get threads info inside Threads console

Additional info:
1.Screenshot attached.
2.Issue exist on OSE:
# openshift version
openshift v3.3.0.26
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

Comment 1 Antonin Stefanutti 2016-08-30 09:01:21 UTC
The Jolokia port needs to be named 'jolokia' so that the link to the Java console shows up in the pod view.

Then I confirm I'm able to reproduce the issue. I'm investigating further and keep you posted.

Comment 2 Antonin Stefanutti 2016-08-30 12:19:19 UTC
Fixes have been pushed upstream in https://github.com/hawtio/hawtio-jmx/pull/20.

Requires a new release of hawtio-jmx then openshift-jvm before updating origin-web-console.

Comment 3 Antonin Stefanutti 2016-08-30 13:52:07 UTC
Upgrade of hawtio-jmx pushed with https://github.com/hawtio/openshift-jvm/pull/5. Requires a new release of openshift-jvm.

Comment 4 Antonin Stefanutti 2016-08-30 13:59:08 UTC
openshift-jvm version 1.0.47 has just been released and can be integrated in origin-web-console.

Comment 5 Jessica Forrester 2016-08-30 21:58:43 UTC
merging to origin in https://github.com/openshift/origin/pull/10722

Comment 6 Troy Dawson 2016-08-31 20:36:03 UTC
This has been merged into ose and is in OSE v3.3.0.28 or newer.

Comment 8 Xia Zhao 2016-09-01 03:37:34 UTC
Verified with  
openshift v3.3.0.28
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

The threads UI is back with good data. Set to verified.

Comment 10 errata-xmlrpc 2016-09-27 09:46:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.