Bug 137118 - Clicking Close button on yes/no boxes performs yes action
Clicking Close button on yes/no boxes performs yes action
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-10-25 16:57 EDT by Derek Anderson
Modified: 2009-04-16 19:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 16:41:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2004-10-25 16:57:07 EDT
Description of problem:
Here's one that might bring major amounts of unintended pain.  As a
rule in the "Are you sure you want to do something possibly damaging?
yes/no" dialogs, if the user clicks the Close button on the dailog (X
in top upper-right window controls) the action should _not_ be taken.
 Currently it is.

Version-Release number of selected component (if applicable):
system-config-lvm-0.9.1-2.5

How reproducible:


Steps to Reproduce:
*** Please don't do this ***
1. Select your root partition in Uninitialized Entities
2. Click "Initialize Entity"
3. At the "Are you certain that you wish to initialize disk entity  
/dev/hda3? All data will be lost on this device/partition." panic and
click the close button.
  
Actual results:
Shot yourself in the foot.  You lost data you didn't want to lose.

Expected results:
Close should be interpreted as safely as possible, i.e. I don't want
to do this.

Additional info:
Comment 1 Jim Parsons 2004-10-26 17:56:31 EDT
Fixed in version 0.9.3
Comment 2 Derek Anderson 2004-11-02 16:41:51 EST
Verified in system-config-lvm-0.9.3-1.0

Note You need to log in before you can comment on or make changes to this bug.