Bug 1371338 - pyanaconda.nm.SettingsNotFoundError: SettingsNotFoundError('ens3',)
Summary: pyanaconda.nm.SettingsNotFoundError: SettingsNotFoundError('ens3',)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:efcc3d08023852af589960f3023...
Keywords:
: 1373134 1373565 (view as bug list)
Depends On:
Blocks: ARMTracker F25BetaBlocker F26AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-08-30 00:02 UTC by Adam Williamson
Modified: 2016-09-13 21:25 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-09-13 21:25:11 UTC


Attachments (Terms of Use)
File: anaconda-tb (488.00 KB, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: anaconda.log (21.60 KB, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: dnf.librepo.log (11.60 KB, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: environ (482 bytes, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: hawkey.log (1.03 KB, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: lsblk_output (1.63 KB, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: lvm.log (211.20 KB, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: nmcli_dev_list (1.26 KB, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: os_info (451 bytes, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: storage.log (82.31 KB, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: syslog (72.54 KB, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: ifcfg.log (687 bytes, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: packaging.log (3.30 KB, text/plain)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details
File: program.log (44.15 KB, application/octet-stream)
2016-08-30 00:02 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2016-08-30 00:02:24 UTC
Description of problem:
Occurs on start of text install with current Rawhide nightly images, right after hitting 2) to say 'install in text mode' rather than 'use VNC'.

Version-Release number of selected component:
anaconda-25.20-1

The following was filed automatically by anaconda:
anaconda 25.20-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/nm.py", line 778, in nm_device_setting_value
    raise SettingsNotFoundError(name)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/tui/spokes/network.py", line 78, in _load_new_devices
    if nm.nm_device_setting_value(name, "connection", "slave-type"):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/tui/spokes/network.py", line 61, in initialize
    self._load_new_devices()
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/tui/hubs/__init__.py", line 65, in setup
    spoke.initialize()
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 47, in setup
    should_schedule = TUIHub.setup(self, environment=environment)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/ui/tui/__init__.py", line 178, in setup
    should_schedule = obj.setup(self.ENVIRONMENT)
  File "/sbin/anaconda", line 1207, in <module>
    anaconda._intf.setup(ksdata)
pyanaconda.nm.SettingsNotFoundError: SettingsNotFoundError('ens3',)

Additional info:
addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-rawh quiet inst.text
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.8.0-0.rc3.git2.1.fc26.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        rawhide

Comment 1 Adam Williamson 2016-08-30 00:02:30 UTC
Created attachment 1195560 [details]
File: anaconda-tb

Comment 2 Adam Williamson 2016-08-30 00:02:32 UTC
Created attachment 1195561 [details]
File: anaconda.log

Comment 3 Adam Williamson 2016-08-30 00:02:34 UTC
Created attachment 1195562 [details]
File: dnf.librepo.log

Comment 4 Adam Williamson 2016-08-30 00:02:35 UTC
Created attachment 1195563 [details]
File: environ

Comment 5 Adam Williamson 2016-08-30 00:02:37 UTC
Created attachment 1195564 [details]
File: hawkey.log

Comment 6 Adam Williamson 2016-08-30 00:02:38 UTC
Created attachment 1195565 [details]
File: lsblk_output

Comment 7 Adam Williamson 2016-08-30 00:02:41 UTC
Created attachment 1195566 [details]
File: lvm.log

Comment 8 Adam Williamson 2016-08-30 00:02:42 UTC
Created attachment 1195567 [details]
File: nmcli_dev_list

Comment 9 Adam Williamson 2016-08-30 00:02:44 UTC
Created attachment 1195568 [details]
File: os_info

Comment 10 Adam Williamson 2016-08-30 00:02:46 UTC
Created attachment 1195569 [details]
File: storage.log

Comment 11 Adam Williamson 2016-08-30 00:02:48 UTC
Created attachment 1195570 [details]
File: syslog

Comment 12 Adam Williamson 2016-08-30 00:02:50 UTC
Created attachment 1195571 [details]
File: ifcfg.log

Comment 13 Adam Williamson 2016-08-30 00:02:51 UTC
Created attachment 1195572 [details]
File: packaging.log

Comment 14 Adam Williamson 2016-08-30 00:02:53 UTC
Created attachment 1195573 [details]
File: program.log

Comment 15 Adam Williamson 2016-08-30 00:06:12 UTC
proposing as an F26 Alpha blocker, per criterion "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces." - https://fedoraproject.org/wiki/Fedora_25_Alpha_Release_Criteria#installer-interfaces . Doesn't appear to affect F25 at least yet. The new openQA text install test catches this in Rawhide (test is live on staging instance, not yet on production).

Comment 16 Jan Sedlák 2016-09-05 11:01:35 UTC
This also started happening on F25 with Fedora-25-20160904.n.0 image.

Comment 17 Jan Sedlák 2016-09-05 11:10:16 UTC
Proposing this as F25 Beta blocker.

Comment 18 Jan Sedlák 2016-09-05 11:10:16 UTC
Proposing this as F25 Beta blocker.

Comment 19 Radek Vykydal 2016-09-05 12:22:45 UTC
https://github.com/rhinstaller/anaconda/pull/769

Comment 20 Christopher Covington 2016-09-06 15:56:08 UTC
*** Bug 1373565 has been marked as a duplicate of this bug. ***

Comment 21 Paul Whalen 2016-09-12 14:53:08 UTC
This issue is fixed with anaconda-25.20.1-1, verified with compose '20160912' and Fedora-Minimal-armhfp-25-20160912.n.0-sda.raw.

Comment 22 Geoffrey Marr 2016-09-13 00:18:28 UTC
Discussed during the 2016-09-12 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker (Beta) was made as this violates Alpha criterion:

"When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-09-12/f25-blocker-review.2016-09-12-16.01.txt

Comment 23 Geoffrey Marr 2016-09-13 01:44:13 UTC
*** Bug 1373134 has been marked as a duplicate of this bug. ***

Comment 24 Adam Williamson 2016-09-13 21:25:11 UTC
I believe we can close this now, the fixed anaconda is stable.


Note You need to log in before you can comment on or make changes to this bug.