Bug 1371353 - posix: Integrate important events with events framework
Summary: posix: Integrate important events with events framework
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1361086 1375914
TreeView+ depends on / blocked
 
Reported: 2016-08-30 01:57 UTC by Pranith Kumar K
Modified: 2017-03-06 17:23 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1375914 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:23:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2016-08-30 01:57:09 UTC
Description of problem:
Integrate important events from posix xlator with events framework.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2016-08-30 02:01:08 UTC
REVIEW: http://review.gluster.org/15342 (storage/posix: Integrate important events with gf_event) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Worker Ant 2016-08-30 02:28:19 UTC
REVIEW: http://review.gluster.org/15342 (storage/posix: Integrate important events with gf_event) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Worker Ant 2016-09-13 23:16:17 UTC
REVIEW: http://review.gluster.org/15342 (storage/posix: Integrate important events with gf_event) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 4 Worker Ant 2016-09-14 08:27:22 UTC
REVIEW: http://review.gluster.org/15342 (storage/posix: Integrate important events with gf_event) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 5 Worker Ant 2016-09-15 03:58:52 UTC
COMMIT: http://review.gluster.org/15342 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 613575ee7140e257d8f0265b719cbfc7c44a0297
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Sep 7 04:19:32 2016 +0530

    storage/posix: Integrate important events with gf_event
    
    BUG: 1371353
    Change-Id: I9346ca16222caf9d97d999751577399ae6aacf72
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/15342
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 6 Shyamsundar 2017-03-06 17:23:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.