Bug 1371398 - [DELL 7.3 BUG] gnome-session reports depreciation of octal literals and escape sequence.
Summary: [DELL 7.3 BUG] gnome-session reports depreciation of octal literals and escap...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell   
(Show other bugs)
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 7.5
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1438583 1454909 1454911 1522983
TreeView+ depends on / blocked
 
Reported: 2016-08-30 07:10 UTC by Purnendu Bhushan
Modified: 2018-05-17 14:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 12:55:16 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages file showing the warning (505.63 KB, text/plain)
2016-08-30 07:10 UTC, Purnendu Bhushan
no flags Details
Use non-deprecated octal notation in downstream patch (821 bytes, patch)
2017-08-15 01:08 UTC, Florian Müllner
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 12:57 UTC

Description Purnendu Bhushan 2016-08-30 07:10:52 UTC
Created attachment 1195642 [details]
/var/log/messages file showing the warning

Description of problem:
After successful installation and boot into RHEL-7.3 alpha and beta in BIOS mode, /var/log/messages shows the following warning messages:
" gnome-session: Gjs-Message: JS WARNING: [resource:///org/gnome/shell/ui/extensionSystem.js 301]: octal literals and octal escape sequences are deprecated
 gnome-session: Gjs-Message: JS WARNING: [resource:///org/gnome/shell/gdm/loginDialog.js 1017]: anonymous function does not always return a value ".


Version-Release number of selected component (if applicable):
gnome-session-3.14.0-5.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1.install RHEL7.3 beta on x86_64 in BIOS mode 
2. boot into OS and check for /Var/log/messages

Actual results:
we can see the warning

Expected results:
no such warning should be there

Additional info:

Comment 2 Purnendu Bhushan 2016-10-06 10:20:20 UTC
Hi Ray ,

I am getting this  issue in rhel 7.3 snapshort 5 also , this bug  is duplicate of bz 1346931 which was  closed as cantfix ,may i know the reson for the js warning and why it was decided not to get fixed.is there a plan to get it fixed in future release

Comment 3 Ray Strode [halfline] 2016-10-06 20:29:29 UTC
This is a legitimate bug and it should get looked at in a future update.

Comment 4 Florian Müllner 2017-06-27 18:13:11 UTC
The deprecated octal syntax warning came up last week on another bug actually. I got a local fix, but didn't consider it freeze-worthy ...

Comment 6 Purnendu Bhushan 2017-07-26 10:40:40 UTC
Hi Florian 

Please provide me the root cause with the fix which you have

Comment 7 Florian Müllner 2017-08-15 01:08 UTC
Created attachment 1313424 [details]
Use non-deprecated octal notation in downstream patch

Comment 8 Florian Müllner 2017-08-15 01:09:52 UTC
(Not sure what you mean by "root cause", but I attached the warning fix now)

Comment 9 Florian Müllner 2017-10-26 16:26:45 UTC
I took the liberty to fix the warning when rebasing the downstream patch for RHEL 7.5 - it should be gone in the latest gnome-shell build.

Comment 11 Michael Boisvert 2018-01-04 18:04:17 UTC
Warnings not present in 3.26.

Comment 14 errata-xmlrpc 2018-04-10 12:55:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.