Bug 13714 - on dp264-class servers megaraid driver gets kernel oops
on dp264-class servers megaraid driver gets kernel oops
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-11 09:27 EDT by Martin Petder
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-11 09:27:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Petder 2000-07-11 09:27:20 EDT
The following kernel oops happens after starting AMI megaraid driver as module or during bootime after driver initialization:

Jul 10 09:28:44 ds20elinux kernel: megaraid: v107 (December 22, 1999) 
Jul 10 09:28:44 ds20elinux kernel: megaraid: found 0x8086:0x1960:idx 0:bus 0:slot 8:func 1 
Jul 10 09:28:44 ds20elinux kernel: scsi2 : Found a MegaRAID controller at 0xa800000, IRQ: 27 
Jul 10 09:28:44 ds20elinux kernel: Unable to handle kernel paging request at virtual address 000000001c96028f 
Jul 10 09:28:44 ds20elinux kernel: CPU 0 modprobe(705): Oops 0 
Jul 10 09:28:44 ds20elinux kernel: pc = [<fffffe00000d7850>]  ra = [<fffffe00000d7958>]  ps = 0000 
Jul 10 09:28:44 ds20elinux kernel: v0 = 000000005c960280  t0 = fffffc00005c1940  t1 = 000000005c9602d0 
Jul 10 09:28:44 ds20elinux kernel: t2 = 0000000000000001  t3 = 0000000000000000  t4 = 0000000000068d58 
Jul 10 09:28:44 ds20elinux kernel: t5 = 000000001c960280  t6 = 000000001c96028f  t7 = fffffc001ca08000 
Jul 10 09:28:44 ds20elinux kernel: s0 = fffffc001ca0bc28  s1 = 000000001c960280  s2 = fffffc001c9600c0 
Jul 10 09:28:44 ds20elinux kernel: s3 = 0000000000000000  s4 = fffffc00005c1940  s5 = 000000005c960280 
Jul 10 09:28:44 ds20elinux kernel: s6 = 0000000000000000  a0 = fffffc001c9600c0  a1 = fffffc001ca0bc28 
Jul 10 09:28:44 ds20elinux kernel: a2 = 0000000000000000  a3 = 0000000000000000  a4 = fffffc001c9600c0 
Jul 10 09:28:44 ds20elinux kernel: a5 = 0000000000000000  t8 = 000000000000270f  t9 = fffffc00005c08c0 
Jul 10 09:28:44 ds20elinux kernel: t10= 0000000000000002  t11= 000000000000000a  pv = fffffc00003235a0 
Jul 10 09:28:44 ds20elinux kernel: at = fffffc000059ef48  gp = fffffe00000e21a8  sp = fffffc001ca0bbb8 
Jul 10 09:28:44 ds20elinux kernel: Code: 
Jul 10 09:28:44 ds20elinux kernel:  40c1f407  addq t5,15,t6 
Jul 10 09:28:44 ds20elinux kernel:  24a50007  ldah t4,7(t4) 
Jul 10 09:28:44 ds20elinux kernel:  22df270f  lda t8,9999(zero) 
Jul 10 09:28:44 ds20elinux kernel:  2fe00000  ldq_u zero,0(v0) 
Jul 10 09:28:44 ds20elinux kernel:  47ff041f  or zero,zero,zero 
Jul 10 09:28:44 ds20elinux kernel:  2fe00000  ldq_u zero,0(v0) 
Jul 10 09:28:44 ds20elinux kernel: *2c26000f  ldq_u t0,15(t5) 
Jul 10 09:28:44 ds20elinux kernel:  482700c1  extbl t0,t6,t0 
Jul 10 09:28:44 ds20elinux kernel: Trace: 31674c 316f64 3167b8 4570f4 457e48 335168 310d38  

System configuration:
DS20E/500Mhz, Adaptec 7xxx scsi, Intel EEPRO/100 nic, AMI Megaraid Express 300 (chip 490),
RedHat Linux 6.2, kernel version 2.2.14,15,16 (contain only minor changes to the driver code)

AMI MEgaraid controllers are marked as tier-3 supported hardware on alpha platform.

Thus
Comment 1 Phil Copeland 2001-06-04 12:08:05 EDT
WHOA there big fella!
the AMI Megariad is *utterly* unsupported on the alpha
Apart from the megaraid requiring to boot it's own BIOS config (not avilable on
alpha) the driver code is hopelessly 32 bit.

Please note that the reasoning for using HW raid in this era has passed and that
software raid now replaces what HW raid used to provide.

Cheers

Phil
=--=
Comment 2 Martin Petder 2001-06-05 04:17:15 EDT
A-hem!

Last time I hear the Megaraid driver was being ported to support IA64 (i.e. was
being written to 64-bit code).

Hopefully it will be done - and then port to the alpha should be trivial? :)
(Unless the code gets even more uglier than it is now...)

Also someone should change the compatibility list of Redhat at
http://www.redhat.com/support/hardware/alpha/6.2/scsi.html
To _not_ include the AMI megaraid adapters..

--
Sabake
Comment 3 Arjan van de Ven 2001-06-05 05:54:38 EDT
The EVIL hack to make megaraid "work" on IA64 contained code unsuitable for
children...

Note You need to log in before you can comment on or make changes to this bug.