Bug 1371436 - vxl-2.0.2 is available
Summary: vxl-2.0.2 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vxl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Raits
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1592564 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-30 08:28 UTC by Upstream Release Monitoring
Modified: 2019-06-19 01:45 UTC (History)
4 users (show)

Fixed In Version: vxl-2.0.2-4.fc30
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-19 01:45:44 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github vxl vxl issues 550 None None None 2019-02-17 11:55:26 UTC

Description Upstream Release Monitoring 2016-08-30 08:28:08 UTC
Latest upstream release: 1.17.0b
Current version/release in rawhide: 1.17.0-20.fc25
URL: http://vxl.sourceforge.net/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/11575/

Comment 1 Upstream Release Monitoring 2016-08-30 08:28:23 UTC
Rebase helper failed.
See logs and attachments in this bugzilla 'NoneType' object has no attribute 'get_rebasehelper_data'

Comment 2 Upstream Release Monitoring 2016-08-30 08:28:39 UTC
Failed to kick off scratch build.

cmd:  rpmbuild -bs /var/tmp/thn-kRk9jJ/vxl.spec
return code:  1
stdout:

stderr:
error: File ./vxl-1.17.0b-clean.tar.gz: No such file or directory

Comment 3 Fedora Admin XMLRPC Client 2016-08-30 09:27:15 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Fedora Admin XMLRPC Client 2016-08-30 09:43:07 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Ankur Sinha (FranciscoD) 2018-11-15 12:18:33 UTC
So, development seems to have moved to Github, and a new release is available from 16th October:

https://github.com/vxl/vxl

I'll see how the new release does. It's needed for quite a few things in Fedora at the moment.

Comment 6 Ankur Sinha (FranciscoD) 2018-11-15 14:27:11 UTC
*** Bug 1592564 has been marked as a duplicate of this bug. ***

Comment 7 Ankur Sinha (FranciscoD) 2018-11-15 16:52:26 UTC
After half a day of looking at it, I've gotten this far:

https://github.com/sanjayankur31/rpm-specs/blob/vxl/vxl.spec

This is where I'm tweaking things to generate patches: https://github.com/sanjayankur31/vxl/tree/fedora-tweaks

At the moment, I've come up to where Mark had gotten: it fails to build because dcmtk in Fedora is much newer than the bundled one, and things have changed (the bundled version is from 2002).

I've filed an issue about it here, but it'll take someone like me that is new to dcmtk development quite a while to update the vxl code to use the new dcmtk. 

https://github.com/vxl/vxl/issues/550

Should/Could we bundle dcmtk in the meantime?

Comment 8 Ankur Sinha (FranciscoD) 2018-11-15 17:38:36 UTC
Upstream do not have time to work on it at the moment: https://github.com/vxl/vxl/issues/550#issuecomment-439122014

Comment 9 Ankur Sinha (FranciscoD) 2019-02-17 12:00:10 UTC
https://github.com/vxl/vxl/releases/tag/v2.0.2

Comment 10 Fedora Update System 2019-05-29 06:54:10 UTC
FEDORA-2019-b0a152dd3b has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b0a152dd3b

Comment 11 Fedora Update System 2019-05-30 13:58:00 UTC
vxl-2.0.2-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b0a152dd3b

Comment 12 Fedora Update System 2019-06-19 01:45:44 UTC
vxl-2.0.2-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.