Bug 1371443 - internal sepolgen testsuite tracebacks
Summary: internal sepolgen testsuite tracebacks
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: policycoreutils
Version: 7.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Lautrbach
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-30 08:56 UTC by Dalibor Pospíšil
Modified: 2017-08-01 16:16 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-08-01 16:16:12 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1883 normal SHIPPED_LIVE policycoreutils bug fix update 2017-08-01 17:53:54 UTC

Description Dalibor Pospíšil 2016-08-30 08:56:06 UTC
Description of problem:
internal test suite stops on traceback

Version-Release number of selected component (if applicable):
policycoreutils-2.5-8.el7

How reproducible:
100%

Steps to Reproduce:
1. rpm -ivh policycoreutils*.src.rpm
2. sed -i 's/^\(make -C sepolgen.*\) all *$/\1 all\n\1 test/' ~/rpmbuild/SPECS/policycoreutils.spec
3. rpmbuild -bc ~/rpmbuild/SPECS/policycoreutils.spec

Actual results:
<snip>
ERROR: test (test_module.TestModuleCompiler)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/root/rpmbuild/BUILD/selinux/sepolgen-1.2.3/tests/test_module.py", line 28, in test
    mc.create_module_package("module_compile_test.te", refpolicy=True)
  File "../src/./sepolgen/module.py", line 175, in create_module_package
    self.refpol_build(sourcename)
  File "../src/./sepolgen/module.py", line 189, in refpol_build
    raise RuntimeError("compilation failed:\n%s" % self.last_output)
RuntimeError: compilation failed:
make[3]: Entering directory `/root/rpmbuild/BUILD/selinux/sepolgen-1.2.3/tests'
Compiling targeted module_compile_test module
/usr/bin/checkmodule:  Module name foo is different than the output base filename module_compile_test
/usr/bin/checkmodule:  loading policy configuration from tmp/module_compile_test.tmp
make[3]: *** [tmp/module_compile_test.mod] Error 1
make[3]: Leaving directory `/root/rpmbuild/BUILD/selinux/sepolgen-1.2.3/tests'

Expected results:
pass

Additional info:
this used to work on policycoreutils-2.2.5-20.el7

Comment 5 errata-xmlrpc 2017-08-01 16:16:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1883


Note You need to log in before you can comment on or make changes to this bug.