Bug 1371447 - cinder WARNING Messages popping in log files continuously.
Summary: cinder WARNING Messages popping in log files continuously.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 8.0 (Liberty)
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Eric Harney
QA Contact: Tzach Shefi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-30 08:59 UTC by VIKRANT
Modified: 2018-01-04 14:28 UTC (History)
7 users (show)

Fixed In Version: openstack-cinder-10.0.0-0.20170220221031.ea70d55.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:32:46 UTC
tshefi: automate_bug-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
Red Hat Knowledge Base (Solution) 2586781 None None None 2016-08-31 05:35:55 UTC

Description VIKRANT 2016-08-30 08:59:26 UTC
Description of problem:

Cu has upgrade the setup from OSP 6 to OSP 8. After the upgrade, Cu is seeing the WARNING messages in cinder log files. Cu wants to get rid of these messages. 

They don't want to alter the logging level but want to know the actual root cause of these errors and how to eliminate these messages. 

Version-Release number of selected component (if applicable):
RHEL OSP 8

How reproducible:
Everytime.

Steps to Reproduce:
1. 
2.
3.

Actual results:
WARNING messages are coming in log file. 

Expected results:
WARNING should not come in log file. 

Additional info:

Below are the messages which are reported by Cu. Adding more messages in next comment. 

~~~
2016-08-29 13:39:58.173 4864 WARNING py.warnings [req-7d7ecad4-3ee2-4f64-b52e-2dd3aacd655b - - - - -] /usr/lib/python2.7/site-packages/oslo_db/sqlalchemy/enginefacade.py:241: NotSupportedWarning: Configuration option(s) ['use_tpool'] not supported
2016-08-29 13:39:58.218 4868 WARNING oslo_log.versionutils [-] Deprecated: RequestBodySizeLimiter() is deprecated as of Kilo in favor of oslo_middleware.RequestBodySizeLimiter and may be removed in Mitaka.
~~~

Comment 4 Robin Cernin 2016-08-30 14:37:09 UTC
Could we please also request backport to OSP 7(Kilo)?

Comment 8 Paul Grist 2017-02-10 00:18:59 UTC
This looks like it landed in stable Ocata, okay to move it to POST for OSP11?

Comment 9 Eric Harney 2017-03-08 19:07:15 UTC
[ novaclient.v1_1 is deprecated ]
2016-08-13 11:15:10.267 1648 WARNING py.warnings [-] /usr/lib/python2.7/site-packages/novaclient/v1_1/__init__.py:30: UserWarning: Module novaclient.v1_1 is deprecated (taken as a basis for novaclient.v2). The preferable way to get client class or object you can find in novaclient.client module.

This warning message should be fixed in Ocata.  The others are mostly warnings that were correctly appearing.  Further issues along these lines can be handled in other bugs.

Comment 11 Tzach Shefi 2017-03-21 18:29:24 UTC
Eric, verifying wise would below be sufficient? 

Install OSP11 (openstack-cinder-10.0.1-0.20170308012116.a7521f5.el7ost) enabled debug=true review logs. 
Unsure which debug level customer used, debug=true should cover all options. 

No warnings/errors as mentioned on comments: #6 (first one) or #7 or #9 were found on Cinder's logs. 

If sufficient I'll changed to verified.

Thanks

Comment 12 Eric Harney 2017-04-05 13:12:40 UTC
(In reply to Tzach Shefi from comment #11)
> Eric, verifying wise would below be sufficient? 
> 
Yes, this looks good to me.

Comment 13 Tzach Shefi 2017-04-05 13:39:26 UTC
Verified, 
See #11-12 above.

Comment 15 errata-xmlrpc 2017-05-17 19:32:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.