Bug 1371539 - Quota version not changing in the quota.conf after upgrading to 3.7.1 from 3.6.1
Summary: Quota version not changing in the quota.conf after upgrading to 3.7.1 from 3.6.1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
Depends On: 1367472
Blocks: 1392715 1392716 1392718
TreeView+ depends on / blocked
 
Reported: 2016-08-30 12:36 UTC by Manikandan
Modified: 2017-03-06 17:23 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1367472
: 1392715 1392716 1392718 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:23:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2016-08-30 12:43:19 UTC
REVIEW: http://review.gluster.org/15352 (glusterd/quota: upgrade quota.conf file during an upgrade) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 2 Worker Ant 2016-08-31 15:22:42 UTC
REVIEW: http://review.gluster.org/15352 (glusterd/quota: upgrade quota.conf file during an upgrade) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

Comment 5 Worker Ant 2016-10-04 09:31:53 UTC
REVIEW: http://review.gluster.org/15352 (glusterd/quota: upgrade quota.conf file during an upgrade) posted (#3) for review on master by Manikandan Selvaganesh (manikandancs333@gmail.com)

Comment 6 Manikandan Selvaganesan 2016-10-12 12:42:31 UTC
glusterd/quota: upgrade quota.conf file during an upgrade

Problem
=======
When quota is enabled on 3.6, it will have quota conf version in quota.conf
as v1.1. This node gets upgraded to 3.7 but it will still have quota conf
version as v1.1 until a quota enable/disable/set limit is initiated. When
this is not initiated and when this node tries to peer probe a node which
is a fresh install of 3.7 (which will have quota conf version as v1.2), then this
will result in "Peer rejected" state.

Comment 7 Worker Ant 2016-11-07 11:58:08 UTC
REVIEW: http://review.gluster.org/15352 (glusterd/quota: upgrade quota.conf file during an upgrade) posted (#4) for review on master by sanoj-unnikrishnan (sunnikri@redhat.com)

Comment 8 Worker Ant 2016-11-07 13:30:24 UTC
REVIEW: http://review.gluster.org/15352 (glusterd/quota: upgrade quota.conf file during an upgrade) posted (#5) for review on master by sanoj-unnikrishnan (sunnikri@redhat.com)

Comment 9 Worker Ant 2016-11-08 04:37:09 UTC
COMMIT: http://review.gluster.org/15352 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 4b2cff614462508eef529c5d128e0974720e3f50
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Tue Aug 30 17:53:09 2016 +0530

    glusterd/quota: upgrade quota.conf file during an upgrade
    
    Problem
    =======
    When quota is enabled on 3.6, it will have quota conf version in quota.conf
    as v1.1. This node gets upgraded to 3.7 but it will still have quota conf
    version as v1.1 until a quota enable/disable/set limit is initiated. When
    this is not initiated and when this node tries to peer probe a node which
    is a fresh install of 3.7 (which will have quota conf version as v1.2), then this
    will result in "Peer rejected" state. This patch fixes the issue.
    
    Solution
    ========
    When an upgrade happens from 3.6 to 3.7, quota.conf file needs
    to be modified as well. With 3.6, in quota.conf the version will be
    v1.1 and it needs to be changed to v1.2 from 3.7. This is because in
    3.7, inode quota feature is introduced. So when an op-version bumpup
    happens quota.conf needs to be upgraded with quota conf version v1.2
    and all the 16 byte uuid needs to be changed to 17 bytes uuid as well.
    
    Previously, when the cluster version is upgraded to 3.7, the quota.conf
    got upgraded as well. But, the upgradation was done only when quota
    enable/disable/set limit is done. With this patch, the upgradation is done
    during a cluster op version bump up as well.
    
    Change-Id: Idb5ba29d3e1ea0e45c85d87c952c75da9e0f99f0
    BUG: 1371539
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/15352
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 10 Worker Ant 2016-11-08 05:16:28 UTC
REVIEW: http://review.gluster.org/15791 (glusterd/quota: upgrade quota.conf file during an upgrade) posted (#1) for review on release-3.8 by sanoj-unnikrishnan (sunnikri@redhat.com)

Comment 11 Shyamsundar 2017-03-06 17:23:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.