Bug 137156 - Japanese messages on swat are unreadable
Japanese messages on swat are unreadable
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Depends On:
  Show dependency treegraph
Reported: 2004-10-26 07:10 EDT by Ryosuke Nanba
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-24 12:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ryosuke Nanba 2004-10-26 07:10:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001

Description of problem:
Swat shows unreadable messages on Japanese environment (ja_JP.UTF-8).
Top page is good. But all other pages (global, shares, etc.) are 

I tried all Japanese encodings (UTF-8, Shift_JIS, EUC-JP, 
ISO-2022-JP), but no encoding made them readable.

adding 'display charset = UTF-8' to global section of /etc/samba/smb.conf
seems to solve this problem.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install FC2 with ja_JP.UTF-8 environment
2. enable swat on service conf
3. access http://localhost:901/globals with web browser which support

Actual Results:  unreadable buttons, comments, etc on the page.

Expected Results:  readable page.
see image: http://www.horobi.com/bugs/swat.png

Additional info:
Comment 1 Jay Fenlason 2004-10-26 10:28:17 EDT
You should also file this upstream at https://bugzilla.samba.org 
Comment 2 Ryosuke Nanba 2004-10-26 13:26:39 EDT
I'm not sure this is samba's bug.
It maybe packaging problem.
So I don't submit this to samba.org at this time.
Comment 3 Jay Fenlason 2004-10-26 13:57:16 EDT
Try uninstalling samba*3.0.7-2.FC2*.rpm, and install the Fedora RPMs from 
www.samba.org (I see them at 
http://us3.samba.org/samba/ftp/Binary_Packages/Fedora/RPMS/i386/core/2/ but 
you may get a different (faster) mirror).  Retry connecting to swat.  If it 
still fails, the problem is definitely an upstream one that you should report 
to bugzilla.samba.org. 
Comment 4 Björn Jacke 2005-01-28 12:29:25 EST
this was an upstream bug having been fixed in the meantime
Comment 5 Jay Fenlason 2005-10-24 12:00:45 EDT
Closed as rawhide as per comment #4. 

Note You need to log in before you can comment on or make changes to this bug.