Bug 1371632 - Connection test passed even fields are blank in proxy dialog
Summary: Connection test passed even fields are blank in proxy dialog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: All
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: Jan Stavel
URL:
Whiteboard:
: 1379251 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-30 16:48 UTC by Jan Stavel
Modified: 2017-08-01 19:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:20:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github RedHatQE rhsm-qe pull 603 None None None 2016-09-19 15:05:07 UTC
Github candlepin subscription-manager pull 1478 None None None 2016-09-06 13:16:35 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Jan Stavel 2016-08-30 16:48:54 UTC
Description of problem:

Test of connection via HTTP proxy was succeeded even fields are blank in proxy setting dialog.


Version-Release number of selected component (if applicable):

   Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)
   ----------------------------     ----------------------------
   arch                             x86_64
   kernel version                   3.10.0-462.el7.x86_64
   ----------------------------     ----------------------------
   server type                      Red Hat Subscription Management
   subscription management server   2.0.16-1
   subscription management rules    5.20
   subscription-manager             1.17.11-1.git.0.cb6afb6.el7
   python-rhsm                      1.17.7-1.git.0.d681692.el7
   ----------------------------     ----------------------------
   Product                          100000000000000_.pem
   69.pem
   ----------------------------     ----------------------------
   Entitlement                       
   ----------------------------     ----------------------------

How reproducible:

everytime


Steps to Reproduce:

  Before a system is unregistered
    and I run subscription-manager-gui
    and I click on System -> Register link
    and I click on "proxy settings" button
  When I check all two checkboxes in a proxy dialog ("I would like to connect via an HTTP proxy" and the next one)
    and I let all fields blank
    and I click on "Test connection" button
  then I see a message "Connection is succeeded" in a status line.


Actual results:

Connection was succeeded appears in status line.


Expected results:

Status message similar to "The fields are still blank" would better describe a current state of proxy settings.


Additional info:

Comment 1 Chris Snyder 2016-09-01 20:19:45 UTC
@candlepin_devs: The fix for this would be to disallow testing connections in the case above.

Comment 2 Chris Snyder 2016-09-26 14:59:42 UTC
*** Bug 1379251 has been marked as a duplicate of this bug. ***

Comment 4 Wei Liu 2017-03-22 01:49:16 UTC
verify this issue when the RHEL7.4 composes start rolling out

Comment 5 Wei Liu 2017-04-01 07:33:48 UTC
Verifying version:
[root@dhcp-128-6 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.4-1.el7
python-rhsm: 1.19.2-1.el7


Verification:
1.Install build RHEL-7.4-20170330.1,and open Subscription Manager GUI.
2.Click on the menu "System -> Configure Proxy"
3.Check "I would like to connect via an HTTP proxy" and leave the proxy url empty
4.Try to click button "Test Connection"
# The "Test Connection" is disabled when the proxy field is blank,so can not use this button to test connection when the proxy is blank.

So this issue is verified and move the status to "verified".

Comment 6 errata-xmlrpc 2017-08-01 19:20:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.