Bug 1371644 - Default enabled plugins must match product support matrix
Summary: Default enabled plugins must match product support matrix
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara
Version: 10.0 (Newton)
Hardware: noarch
OS: Linux
unspecified
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Telles Nobrega
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-30 17:23 UTC by Elise Gafford
Modified: 2016-12-14 15:54 UTC (History)
5 users (show)

Fixed In Version: openstack-sahara-5.0.0-2.el7ost
Doc Type: No Doc Update
Doc Text:
-
Clone Of:
Environment:
Last Closed: 2016-12-14 15:54:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Elise Gafford 2016-08-30 17:23:46 UTC
Description of problem:

Sahara upstream supports several plugins which are not supported downstream. In the Sahara downstream product, we intend to support:

1) CDH 5.5 and 5.7
2) Ambari 2.3 and 2.4
3) MapR 5.1

All other plugins and plugin versions should be disabled.

Comment 6 Luigi Toscano 2016-11-03 18:55:29 UTC
The list of default plugins have been changed to show only the relevant ones.

This is not valid for TripleO deployments, as TripleO overwrites the list of plugins. There is a work in progress to make this configurable, but out of scope for now:
https://bugs.launchpad.net/tripleo/+bug/1560098

The disabled plugin versions are shown anyway by
$ openstack dataprocessing plugin list
but are correctly hidden by the Sahara Horizon UI, so this may be a bug for python-saharaclient.

Comment 7 Luigi Toscano 2016-11-28 09:44:54 UTC
(In reply to Luigi Toscano from comment #6)

> The disabled plugin versions are shown anyway by
> $ openstack dataprocessing plugin list
> but are correctly hidden by the Sahara Horizon UI, so this may be a bug for
> python-saharaclient.


Even if `openstack dataprocessing plugin list` shows all the versions of each plugin, the disabled versions are correctly marked as "disabled" when `openstack dataprocessing plugin show <version>` is used. It seems either an oversight or a bug in python-saharaclient, reported as https://bugs.launchpad.net/python-saharaclient/+bug/1644482.
but definitely not critical.

So closing this for now.

Verified on:
openstack-sahara-api-5.0.0-3.el7ost.noarch
openstack-sahara-common-5.0.0-3.el7ost.noarch
openstack-sahara-engine-5.0.0-3.el7ost.noarch
openstack-sahara-ui-5.0.0-3.el7ost.noarch
python-sahara-5.0.0-3.el7ost.noarch
python-saharaclient-0.18.0-1.el7ost.noarch

Comment 9 errata-xmlrpc 2016-12-14 15:54:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.