Bug 1371650 - [Open SSL] : Unable to mount an SSL enabled volume via SMB v3/Ganesha v4
Summary: [Open SSL] : Unable to mount an SSL enabled volume via SMB v3/Ganesha v4
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.8
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: rjoseph
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On: 1340608 1362602 1371475
Blocks: Gluster-HC-2 1311843
TreeView+ depends on / blocked
 
Reported: 2016-08-30 17:32 UTC by rjoseph
Modified: 2016-09-16 18:28 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.8.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1362602
Environment:
Last Closed: 2016-09-16 18:28:44 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2016-08-30 17:34:50 UTC
REVIEW: http://review.gluster.org/15359 (socket: SSL_shutdown should be called before socket shutdown) posted (#1) for review on release-3.8 by Rajesh Joseph (rjoseph@redhat.com)

Comment 2 Worker Ant 2016-08-30 17:37:09 UTC
REVIEW: http://review.gluster.org/15361 (gfapi: SSL connection for mgmt connection is not working) posted (#1) for review on release-3.8 by Rajesh Joseph (rjoseph@redhat.com)

Comment 3 Worker Ant 2016-08-31 11:45:43 UTC
COMMIT: http://review.gluster.org/15359 committed in release-3.8 by Kaushal M (kaushal@redhat.com) 
------
commit 8eebc4c960366e8ff26751914654ccc21bb1a6fd
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Tue Aug 2 15:30:27 2016 +0000

    socket: SSL_shutdown should be called before socket shutdown
    
    SSL_shutdown shuts down an active SSL connection. But we
    are calling this after underlying socket is disconnected.
    
    > Change-Id: Ia943179d23395f42b942450dbcf26336d4dfc813
    > BUG: 1362602
    > Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    > Reviewed-on: http://review.gluster.org/15072
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    (cherry picked from commit 79e006b31a1e6d71f1af02176f8e8acaed7f8cd2)
    
    Change-Id: I6ce58bd5606278880e44c96d386acaeb0fef6275
    BUG: 1371650
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/15359
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 4 Worker Ant 2016-08-31 13:01:27 UTC
REVIEW: http://review.gluster.org/15361 (gfapi: SSL connection for mgmt connection is not working) posted (#2) for review on release-3.8 by Rajesh Joseph (rjoseph@redhat.com)

Comment 5 Worker Ant 2016-08-31 21:23:18 UTC
COMMIT: http://review.gluster.org/15361 committed in release-3.8 by Jeff Darcy (jdarcy@redhat.com) 
------
commit ecb8d38d34c6cdd16e34bbe40d3e64e9d1cc9909
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Tue Aug 2 15:33:34 2016 +0000

    gfapi: SSL connection for mgmt connection is not working
    
    Problem: libgfapi does not enable SSL on mgmt connection.
    
    Fix: Enable SSL when it is enabled on mgmt connection is enabled,
    i.e. presence of /var/lib/glusterd/secure-access file
    
    > Change-Id: I1ce4935b04e6140aeab819e42076defd580b0727
    > BUG: 1362602
    > Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    > Reviewed-on: http://review.gluster.org/15073
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-by: Kaushal M <kaushal@redhat.com>
    (cherry picked from commit 62f4e41e9eafd2838d2a11989f08b0e7627284b4)
    
    Change-Id: I282729825229e961f03b7f8e8a9fa0aa2c8fc6a7
    BUG: 1371650
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/15361
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 6 Niels de Vos 2016-09-12 05:36:58 UTC
All 3.8.x bugs are now reported against version 3.8 (without .x). For more information, see http://www.gluster.org/pipermail/gluster-devel/2016-September/050859.html

Comment 7 Niels de Vos 2016-09-16 18:28:44 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.4, please open a new bug report.

glusterfs-3.8.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/announce/2016-September/000060.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.