Bug 137170 - 'Coda' module not built by default
'Coda' module not built by default
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: dff
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-26 10:11 EDT by Tim Skirvin
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 16:36:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Skirvin 2004-10-26 10:11:10 EDT
Description of problem:  There is no 'coda' module installed by default


Version-Release number of selected component (if applicable):
Testing on RHEL Desktop 3


How reproducible: occurs every time.



Steps to Reproduce:
1.  'modprobe coda'
2.
3.
  
Actual results:
modprobe: Can't locate module coda

Expected results:
(no result; lsmod shows it in loaded modules)


Additional info:
The kernel module should be built.
Comment 1 Ernie Petrides 2004-10-26 18:27:02 EDT
This is a feature request.  The fs/coda module is actually built,
but it is listed in the linux-modules-unsupported list.
Comment 2 Suzanne Hillman 2004-10-27 16:10:16 EDT
Internal RFE bug #137368 entered; will be considered for future releases.
Comment 4 Tim Skirvin 2004-12-13 14:06:58 EST
As there is only one way to get coda functionality - put it in the
kernel - this is much more important than "we'll do this in a future
release, maybe".  I absolutely need this functionality, and I still
want to use your kernels.  What should I do?
Comment 5 Ernie Petrides 2004-12-13 16:36:18 EST
Tim, you can install the appropriate kernel-[smp-]supported-* RPM
to get coda functionality.  We have no idea if it will work, nor
do intend to support it in future RHEL releases.
Comment 6 Tim Skirvin 2004-12-13 16:40:20 EST
Where could I find these kernels in the RedHat Network interface?

Why are you not planning on supporting this in the future?
Comment 7 Ernie Petrides 2004-12-13 17:31:01 EST
Tim, the "kernel-unsupported" RPMs simply contain modules that can be
installed in addition to the base RPMs.  For example, if you install
kernel-smp-2.4.21-20.0.1.EL as your base kernel, then you can augment
it with kernel-smp-unsupported-2.4.21-20.0.1.EL.  These are the x86 SMP
packages in the "Red Hat Enterprise Linux AS (v. 3 for x86)" RHN channel
at the moment.

As for not supporting the Coda filesystem in the future, apparently RH
Product Management doesn't feel there is enough business justification.
Comment 8 Tim Burke 2004-12-13 20:51:08 EST
Supporting a new filesystem responsibly requires a substantial
development and support effort.  For enterprise customers, they demand
support, QA, bugfixes, performance enhancements and security errata.
So we can't just throw in Coda on an "as-is" basis.

We haven't seen the business justification to warrant staffing up Coda
support.
Comment 9 Tim Skirvin 2004-12-14 15:02:20 EST
Since it's in the 'unsupported' list, and therefore builds as well as
the kernel itself, I'm content.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.