Bug 137174 - Lack of fsck.hfsplus + hfsplus driver pickiness = read only mount
Lack of fsck.hfsplus + hfsplus driver pickiness = read only mount
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hfsutils (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
: FutureFeature, Reopened
Depends On:
Blocks: fedora-ppc
  Show dependency treegraph
 
Reported: 2004-10-26 10:44 EDT by W. Michael Petullo
Modified: 2011-10-28 06:51 EDT (History)
6 users (show)

See Also:
Fixed In Version: 3.2.6-6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-28 06:51:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2004-10-26 10:44:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040626 Firefox/0.8

Description of problem:
Within its hfs code, the kernel contains the following code fragment:

if ((attrib & cpu_tobe16(HFS_SB_ATTRIB_UNMNT))
    || (attrib & cpu_to_be16(HFS_SB_ATTRIB_INCNSTNT))) {
        hfs_warn("HFS-fs warning: Filesystem was not cleanly unmounted,
                 "running fsck.hfs is recommended.  mounting
read-only.\n");
        sb->s_flags |= MS_RDONLY;
}

Because fsck.hfs is not provided, this causes a filesystem that was
not properly unmounted to mount read only forever.  The only fix seems
to be to boot into something like Mac OS X to repair the filesystem.

Either fsck.hfs should be implemented or this paranoia should be
removed from the kernel filesystem code.  Of course, option two may
not be safe.  Note that hfsutils' TODO does make mention of hfsck.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.643

How reproducible:
Always

Steps to Reproduce:
1.  Improperly remove an HFS drive from the system (do not properly
unmount it).

2.  Try to mount the drive.

Actual Results:  The kernel mounts it read only.
    

Additional info:
Comment 1 David Woodhouse 2005-02-20 08:31:05 EST
hfsutils-3.2.6-6 includes hfsck.
Comment 2 W. Michael Petullo 2005-02-21 10:54:07 EST
Has anyone tried hfsck?  It seems to like to eat filesystems more than
fix them.  On my system, running hfsck rendered an HFS+ filesystem
unmountable.

Also, there is no fsck.hfsplus link, so "fsck /dev/hdaX" says:

fsck 1.35 (28-Feb-2004)
fsck: fsck.hfsplus: not found
fsck: Error 2 while executing fsck.hfsplus for /dev/hda7
Comment 3 David Woodhouse 2005-02-21 10:58:08 EST
hfsck isn't for hfs+
Comment 4 W. Michael Petullo 2005-02-21 11:11:04 EST
That explains a lot.  Well, since hfs+ is what I am looking for, I changed the
bug summary.  I think most people use hfs+ these days, right?
Comment 5 David Woodhouse 2005-02-21 11:29:17 EST
We should put hfsplusutils into Fedora Extras.

http://david.woodhou.se/hfsplusutils-1.0.4-2.src.rpm
Comment 6 Arenas Belon, Carlo Marcelo 2005-03-07 02:02:44 EST
the current hfsplusutils code needs lots of cleaning first to compile cleanly
with gcc3.4 (default on fc3) and later.

the spec is also not good for Fedora Extra, eventhough only needed minor tweaks.
Comment 7 K.R. Foley 2005-03-09 21:09:21 EST
In addition, I tried every combination of hpfsck after building it with the
above package. Didn't seem to make any difference at all. However mounting the
fs with "./hpmount /dev/sda3" and then unmounting with "./hpumount" fixes the
problem. Just fyi.
Comment 8 W. Michael Petullo 2006-03-20 08:35:30 EST
fsck.hfsplus from the hfsplusutils-1.0.4-6 package seems to corrupt HFS+
filesystems.
Comment 9 Red Hat Bugzilla 2007-02-05 14:24:08 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 11 Karsten Hopp 2011-10-28 06:51:34 EDT
we have fsck.hfsplus in the latest Fedora for PPC, closing

Note You need to log in before you can comment on or make changes to this bug.