Bug 1371757 - dl_poly_openmpi can't find libmpi_f90.so.1
Summary: dl_poly_openmpi can't find libmpi_f90.so.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: dl_poly
Version: epel7
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Love
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-31 03:07 UTC by Norman Gaywood
Modified: 2016-09-15 21:47 UTC (History)
2 users (show)

Fixed In Version: dl_poly-1.9.20140324-16.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-15 21:47:49 UTC


Attachments (Terms of Use)

Description Norman Gaywood 2016-08-31 03:07:25 UTC
Description of problem:

$ dl_poly_openmpi 
dl_poly_openmpi: error while loading shared libraries: libmpi_f90.so.1: cannot open shared object file: No such file or directory

Version-Release number of selected component (if applicable):
dl_poly-1.9.20140324-7.el7.x86_64
dl_poly-openmpi-1.9.20140324-7.el7.x86_64
openmpi-1.10.0-10.el7.x86_64
compat-openmpi16-1.6.4-10.el7.x86_64

How reproducible:
Always fails

Steps to Reproduce:
1. Install packages
2. Run 'module load mpi/openmpi-x86_64'
3. Run 'dl_poly_openmpi'

Actual results:
dl_poly_openmpi: error while loading shared libraries: libmpi_f90.so.1: cannot open shared object file: No such file or directory

Expected results:
dl_poly_openmpi should not fail on loading a library

Additional info:
libmpi_f90.so.1 is in the package compat-openmpi16-1.6.4-10.el7.x86_64
However, if I 'module load mpi/compat-openmpi16-x86_64' there is no PATH to dl_poly_openmpi

Can't module load both modules mpi/openmpi-x86_64 and mpi/compat-openmpi16-x86_64

Comment 1 Fedora Update System 2016-08-31 13:20:47 UTC
dl_poly-1.9.20140324-16.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-bbd2467c14

Comment 2 Fedora Update System 2016-08-31 15:18:47 UTC
dl_poly-1.9.20140324-16.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-bbd2467c14

Comment 3 Fedora Update System 2016-09-15 21:47:46 UTC
dl_poly-1.9.20140324-16.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.