Bug 1371848 - Installation of ceph-installer failing on RHEL 7.3 because of conflicts with file from package firewalld-filesystem
Summary: Installation of ceph-installer failing on RHEL 7.3 because of conflicts with ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 2
Assignee: Ken Dreyer (Red Hat)
QA Contact: Daniel Horák
URL:
Whiteboard:
: 1433124 (view as bug list)
Depends On:
Blocks: Console-2-Async 1375561
TreeView+ depends on / blocked
 
Reported: 2016-08-31 09:18 UTC by Daniel Horák
Modified: 2017-03-16 21:08 UTC (History)
13 users (show)

Fixed In Version: RHEL: ceph-installer-1.0.15-2.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-19 15:22:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2016:2082 0 normal SHIPPED_LIVE Moderate: Red Hat Storage Console 2 security and bug fix update 2017-04-18 19:29:02 UTC

Description Daniel Horák 2016-08-31 09:18:42 UTC
Description of problem:
  It is not possible to install ceph-installer on RHEL 7.3 Beta, because of:
  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  Transaction check error:
    file /usr/lib/firewalld/services from install of ceph-installer-1.0.15-1.el7scon.noarch conflicts with file from package firewalld-filesystem-0.4.3.2-4.el7.noarch
  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Version-Release number of selected component (if applicable):
  Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)
  ceph-installer-1.0.15-1.el7scon.noarch
  firewalld-filesystem-0.4.3.2-4.el7.noarch

How reproducible:
  100%

Steps to Reproduce:
1. Install RHEL 7.3 Beta
2. Try to install ceph-installer

Actual results:
  Transaction check error:
    file /usr/lib/firewalld/services from install of ceph-installer-1.0.15-1.el7scon.noarch conflicts with file from package firewalld-filesystem-0.4.3.2-4.el7.noarch

Expected results:
  It is possible to install ceph-installer on RHEL 7.3.

Additional info:
  Directory /usr/lib/firewalld/services should not be owned by ceph-installer package.

Comment 6 Ken Dreyer (Red Hat) 2016-09-13 16:21:06 UTC
upstream fix in https://github.com/ceph/ceph-installer/pull/169

Comment 9 Daniel Horák 2016-09-26 11:43:26 UTC
Tested and VERIFIED with:
  Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)

  ceph-installer-1.0.15-2.el7scon.noarch
  firewalld-0.4.3.2-4.el7.noarch
  firewalld-filesystem-0.4.3.2-4.el7.noarch

>> VERIFIED

Comment 10 errata-xmlrpc 2016-10-19 15:22:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2016:2082

Comment 11 Ken Dreyer (Red Hat) 2017-03-16 21:08:31 UTC
*** Bug 1433124 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.