Bug 1371874 - [RFE] DHT Events
Summary: [RFE] DHT Events
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On: 1361066
Blocks: 1376477
TreeView+ depends on / blocked
 
Reported: 2016-08-31 10:20 UTC by Nithya Balachandran
Modified: 2017-03-06 17:24 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: Enhancement
Doc Text:
Clone Of: 1361066
: 1376477 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:24:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2016-08-31 10:20:34 UTC
+++ This bug was initially created as a clone of Bug #1361066 +++

Description of problem:

This RFE is to track the changes required in the DHT component to generate the events to be consumed by the eventing framework.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2016-08-31 10:26:22 UTC
REVIEW: http://review.gluster.org/15373 (events/dht: dht cli events) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 2 Worker Ant 2016-09-14 15:36:35 UTC
REVIEW: http://review.gluster.org/15500 (events/dht: dht cli events) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 3 Worker Ant 2016-09-15 05:55:15 UTC
REVIEW: http://review.gluster.org/15500 (events/dht: dht cli events) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 4 Worker Ant 2016-09-15 05:55:20 UTC
REVIEW: http://review.gluster.org/15501 (dht/events:  Added rebalance events) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 5 Worker Ant 2016-09-15 13:15:36 UTC
COMMIT: http://review.gluster.org/15500 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 957e40060734f1a0b2d9e3d37c4b0f7961f56b51
Author: N Balachandran <nbalacha@redhat.com>
Date:   Wed Sep 14 20:12:42 2016 +0530

    events/dht: dht cli events
    
    Adding events for add/remove brick and rebalance
    from the cli.
    
    Change-Id: I4e07cb7224e1b63a2926db055f87a02220c5d043
    BUG: 1371874
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/15500
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 6 Worker Ant 2016-09-16 09:37:36 UTC
REVIEW: http://review.gluster.org/15501 (dht/events:  Added rebalance events) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)

Comment 7 Worker Ant 2016-09-16 15:31:35 UTC
COMMIT: http://review.gluster.org/15501 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit e872917dbf4563703b8f396d7d30f8168ed646cd
Author: N Balachandran <nbalacha@redhat.com>
Date:   Thu Sep 15 11:20:54 2016 +0530

    dht/events:  Added rebalance events
    
    The rebalance process will now send an event when it is
    complete.
    Also fixed a problem where the run-time was not always
    set causing spurious rebalance failure events to be sent.
    
    Change-Id: Ib445171c78c9560940022bca20c887d31a9bb1ca
    BUG: 1371874
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/15501
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 8 Shyamsundar 2017-03-06 17:24:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.