Bug 137191 - /usr/bin/firefox sets LD_LIBRARY_PATH incorrectly
Summary: /usr/bin/firefox sets LD_LIBRARY_PATH incorrectly
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-26 16:42 UTC by Steve Knodle
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-31 09:17:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Knodle 2004-10-26 16:42:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040719 Firefox/0.9.1

Description of problem:
Because of what obviously is a typo:
If LD_LIBRARY_PATH is not already set prior to invocation,
"/usr/bin/firefox" incorrectly sets LD_LIBRARY_PATH to the
same directory repeated twice, instead of a directory and a
subdirectory.  Consequently, firefox hangs when invoked, not
opening a window or anything.

Version-Release number of selected component (if applicable):
0.9.1

How reproducible:
Always

Steps to Reproduce:
1. Run "/usr/bin/firefox" when LD_LIBRARY_PATH is not set.
2.
3.
    

Actual Results:  firefox is running (seen using "ps ax") but no window
opens.
Process must be killed manually.

Expected Results:  Open a window on default home page...

Additional info:

The  correction is here:
Bad code line commented out below.  
##
## Set LD_LIBRARY_PATH
##
if [ "$LD_LIBRARY_PATH" ]
then
  LD_LIBRARY_PATH=$MOZ_DIST_BIN:$MOZ_DIST_BIN/plugins:$LD_LIBRARY_PATH
else
  # slk@bu.edu, the following line is bad:
  # LD_LIBRARY_PATH=$MOZ_DIST_BIN:$MOZ_DIST_BIN
  LD_LIBRARY_PATH=$MOZ_DIST_BIN:$MOZ_DIST_BIN/plugins
fi
                                                                     
          
export LD_LIBRARY_PATH

Comment 1 Warren Togami 2004-10-31 09:17:01 UTC
I cannot reproduce the bad behavior that you mention, which I suspect
is unrelated to this LD_LIBRARY_PATH problem.  I am testing the below
patch before committing.

--- firefox.orig        2004-10-30 23:19:53.842473953 -1000
+++ firefox     2004-10-30 23:20:08.025959165 -1000
@@ -55,7 +55,7 @@
 then
   LD_LIBRARY_PATH=$MOZ_DIST_BIN:$MOZ_DIST_BIN/plugins:$LD_LIBRARY_PATH
 else
-  LD_LIBRARY_PATH=$MOZ_DIST_BIN:$MOZ_DIST_BIN
+  LD_LIBRARY_PATH=$MOZ_DIST_BIN:$MOZ_DIST_BIN/plugins
 fi

 export LD_LIBRARY_PATH


Comment 2 Jakub Jelinek 2004-10-31 09:21:58 UTC
LD_LIBRARY_PATH=$MOZ_DIST_BIN:$MOZ_DIST_BIN/plugins${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
without any if is better - there is just one place where the path
is set, so having the prepended library paths not in sync is not
possible.


Note You need to log in before you can comment on or make changes to this bug.