Bug 1372045 - Metadata for Instances doesn't work on a setup with DVR
Summary: Metadata for Instances doesn't work on a setup with DVR
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Brent Eagles
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-31 18:54 UTC by Sai Sindhur Malleni
Modified: 2016-12-14 15:55 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:55:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 373141 None None None 2016-09-21 17:25:24 UTC
OpenStack gerrit 373544 None None None 2016-09-21 17:25:54 UTC
Launchpad 1625504 None None None 2016-09-21 17:24:58 UTC

Description Sai Sindhur Malleni 2016-08-31 18:54:43 UTC
Description of problem: Instances are unable to get metadata when booted with --user-data. Key injection also fails. Instances cannot even ping 169.254.169.254
Looking at with Brent Eagles, looks like nova_metadata_ip is not configured by TripleO.

Version-Release number of selected component (if applicable):
RHOP 10
Puddle- 2016-08-24.1
How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP using DVR
2. Boot instance injecting key, or passing --user-data
3.

Actual results:
Instances fail to get metadata, although they have a route configured for metadata. Also, can't ping 169.254.169.254 even if the route has been configured.

Expected results:
Instance should be able to ping metadata IP, fetch metadata.

Additional info:

Comment 2 Brent Eagles 2016-09-16 19:53:54 UTC
This issue had been resolved upstream through a unrelated refactoring/cleanup. 

https://review.openstack.org/#/c/361362/

It appears that the change has already been pulled into our current packages.

Comment 3 Brent Eagles 2016-09-21 17:24:58 UTC
The change that was made to the heat templates were insufficient. The required changes were made and merged upstream.

Comment 6 Alexander Stafeyev 2016-10-19 06:12:43 UTC
Tested metadata on dvr environment. 


[root@vm-1 ~]# ip route 
default via 25.25.25.1 dev eth0  proto static  metric 100 
25.25.25.0/24 dev eth0  proto kernel  scope link  src 25.25.25.3  metric 100 
169.254.169.254 via 25.25.25.1 dev eth0  proto dhcp  metric 100 
[root@vm-1 ~]# curl http://169.254.169.254/
1.0
2007-01-19
2007-03-01
2007-08-29
2007-10-10
2007-12-15
2008-02-01
2008-09-01
2009-04-04

there is connectivity. 

tack@undercloud-0 ~]$ rpm -qa| grep openstack-tripleo-heat
openstack-tripleo-heat-templates-5.0.0-0.20160929150845.4cdc4fc.el7ost.noarch

Comment 9 errata-xmlrpc 2016-12-14 15:55:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.