Bug 137212 - cdrecord scanbus returns incorrect information for USB burner
cdrecord scanbus returns incorrect information for USB burner
Status: CLOSED DUPLICATE of bug 134822
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-26 14:33 EDT by Joshua Bergland
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Bergland 2004-10-26 14:33:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Just installed a fresh install of FC3-r1

I have an external USB dvd burner. It is correctly discovered by the
kernel and here is the messages from dmesg:

SCSI subsystem initialized
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
  Vendor: _NEC      Model: DVD_RW ND-2500A   Rev: 1.07
  Type:   CD-ROM                             ANSI SCSI revision: 02
USB Mass Storage device found at 2
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
usb 3-2: new full speed USB device using address 2

This is correct and an improvement over previous kernel version where
it was incorrectly found as a Revoltec device.


The problem is that when I run 'cdrecord -scanbus' I get weird
results, and not always the same response. For example:

cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c 1.83
04/05/20 Copyright 1997 J. Schilling').
scsibus0:
        0,0,0     0) '���'
'���' '���' Removable
unknown device type 0x1f
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *

cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c 1.83
04/05/20 Copyright 1997 J. Schilling').
scsibus0:
        0,0,0     0) ' 7) *
��' '' '���'
'���' Re' 'mova' Communication
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *

cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus0:
        0,0,0     0) 'ADAPTEC ' 'ACB-5500        ' 'FAKE' NON CCS Disk
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *


This happens as both an user account and as root. Running 'cdrecord
-scanbus dev=ATA' correctly responds with my two IDE devices:
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c 1.83
04/05/20 Copyright 1997 J. Schilling').
scsibus0:
        0,0,0     0) 'TDK     ' 'CDRW161040X     ' '5.32' Removable CD-ROM
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
scsibus1:
        1,0,0   100) 'IDE     ' 'DVD-ROM 16X     ' '7.92' Removable CD-ROM
        1,1,0   101) *
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *

This may also effect k3b which also does not see the burner, only the
two IDE devices.

Version-Release number of selected component (if applicable):
cdrecord-2.01.1-5

How reproducible:
Always

Steps to Reproduce:
1. Install FC3-r1
2. Connect USB dvd burner
3. Run 'cdrecord -scanbus'
    

Actual Results:  See description

Expected Results:  Expect to see:

cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus0:
        0,0,0     0) '_NEC     ' 'DVD_RW ND-2500A  ' '1.07' Removable
CD-ROM
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *

Additional info:
Comment 1 Harald Hoyer 2004-10-27 04:30:44 EDT

*** This bug has been marked as a duplicate of 134822 ***
Comment 2 Joshua Bergland 2004-10-27 10:27:16 EDT
Tried to add this to bug 134822, but was told I don't have permission
to edit RHEL bugs.

I am reporter of bug 137212. As mentioned in this bug report, I put a
disc in the drive. As others have mentioned, it reports correctly with
a disc in the drive and even k3b finds the drive as long as a disc is in.

Should still work when the drive is empty.
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.