Bug 1372136 - Unresolved symbols in libnfsidmap prevent rpc.idmapd from starting
Summary: Unresolved symbols in libnfsidmap prevent rpc.idmapd from starting
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libnfsidmap
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1372104 1372489 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-01 01:50 UTC by Loïc Yhuel
Modified: 2016-12-05 19:11 UTC (History)
9 users (show)

Fixed In Version: libnfsidmap-0.26-6.rc4.fc24 libnfsidmap-0.26-6.rc4.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-04 00:51:55 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Loïc Yhuel 2016-09-01 01:50:20 UTC
Description of problem:
rpc.idmapd[23814]: /usr/sbin/rpc.idmapd: symbol lookup error: /lib64/libnfsidmap.so.0: undefined symbol: __dn_expand


Version-Release number of selected component (if applicable):
libnfsidmap-0.26-5.rc4.fc24.x86_64

How reproducible:
Try to launch rpc.idmapd

Additional info:
# ldd -r /lib64/libnfsidmap.so.0
        linux-vdso.so.1 (0x00007ffe7df64000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f7dc223e000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f7dc1e7c000)
        /lib64/ld-linux-x86-64.so.2 (0x000055fcc0540000)
undefined symbol: __dn_expand   (/lib64/libnfsidmap.so.0)
undefined symbol: __res_querydomain     (/lib64/libnfsidmap.so.0)
undefined symbol: __dn_skipname (/lib64/libnfsidmap.so.0)

From Koji logs :
 - x86_64 and armv7hl have an issue in configure : checking for res_querydomain in -lresolv... no
 - i686 works : checking for res_querydomain in -lresolv... yes
This is strange, since the symbol in present in /lib/libresolv-2.23.so.

Comment 1 Arif Saleem 2016-09-01 11:49:11 UTC
Hi
I'm not sure if this is related, but today I had an issue due to this new version of libnfsidmap-0.26-5.rc4

Scenario :
- NFS Server is CentOS 6.8
- Client is Fedora 24 and mounts home directories over NFS4
The setup has been working fine.

After the update on the Fedora Client to libnfsidmap-0.26-5.rc4 the mounted files and directories on the client started to show up with user/group IDs of 4294967294:4294967294

I rebooted the client, same problem. Restarted rpcidmapd on the server, same problem.

Finally I realised that libnfsidmap had been updated just this morning, so I downgraded back to libnfsidmap-0.26-4.2.fc24.x86_64 and then remounted, and now all is OK again.

So something seems to be rather wrong in the new libnfsidmap-0.26-5.rc4 package.

HTH

Comment 2 Ed Greshko 2016-09-01 11:57:56 UTC
(In reply to Arif Saleem from comment #1)

> After the update on the Fedora Client to libnfsidmap-0.26-5.rc4 the mounted
> files and directories on the client started to show up with user/group IDs
> of 4294967294:4294967294

Yes, that is a symptom of this bug.

Comment 3 John Florian 2016-09-01 17:49:25 UTC
I can confirm this bug.  It just bit our whole team and first became evident when ownership of our NFS-mounted homes started showing 4294967294/4294967294.

We had to dnf downgrade to get things working again.

Comment 4 Fedora Update System 2016-09-02 14:34:47 UTC
libnfsidmap-0.26-6.rc4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-285540258b

Comment 5 Fedora Update System 2016-09-02 14:34:57 UTC
libnfsidmap-0.26-6.rc4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-625bd99661

Comment 6 jamespharvey20 2016-09-03 03:09:47 UTC
*** Bug 1372489 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2016-09-03 03:22:55 UTC
libnfsidmap-0.26-6.rc4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-625bd99661

Comment 8 Fedora Update System 2016-09-03 03:52:57 UTC
libnfsidmap-0.26-6.rc4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-285540258b

Comment 9 Fedora Update System 2016-09-04 00:51:50 UTC
libnfsidmap-0.26-6.rc4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-09-08 21:15:11 UTC
libnfsidmap-0.26-6.rc4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Steve Dickson 2016-12-05 19:11:08 UTC
*** Bug 1372104 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.