Bug 1372183 - python-libs rewheel/__init__.py is missing last 15 lines
Summary: python-libs rewheel/__init__.py is missing last 15 lines
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Charalampos Stratakis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1283658 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-01 06:58 UTC by John Vandenberg
Modified: 2016-09-10 03:21 UTC (History)
12 users (show)

Fixed In Version: python-2.7.11-10.fc23 python-2.7.12-5.fc24 python-2.7.12-6.fc25
Doc Type: Bug Fix
Doc Text:
Cause: Incorrect patching of ensurepip/rewheel Consequence: ensurepip fails when pip is not present Fix: Rebase patch Result: ensurepip works correctly
Clone Of:
Environment:
Last Closed: 2016-09-05 22:51:44 UTC
Type: Bug


Attachments (Terms of Use)

Description John Vandenberg 2016-09-01 06:58:17 UTC
Description of problem:
rewheel/__init__.py installed onto systems does not have the last 15 lines that appear at https://github.com/fedora-python/rewheel/blame/master/rewheel/__init__.py#L141 onwards

The 15 lines appear in python3-libs' rewheel/__init__.py .

Version-Release number of selected component (if applicable):
1. 2.7.11-8.fc23
2. 2.7.12-2.fc24
3. 2.7.12-3.fc25
4. 2.7.12-3.fc26

How reproducible:
Very

Steps to Reproduce:
1. Downloads any python-libs rpm on https://apps.fedoraproject.org/packages/python-libs for fc23-26
2. Unpack the rpm
3. tail ./usr/lib*/python2.7/ensurepip/rewheel/__init__.py

Actual results:
The last 15 lines are missing.

Expected results:
The last 15 lines are present.

Additional info:
With 15 lines missing, the function get_records_to_pack returns nothing, causing python -e ensurepip fails when python-pip is missing, showing the following backtrace:

$ sudo python -m ensurepip
Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 174, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib64/python2.7/ensurepip/__main__.py", line 4, in <module>
    ensurepip._main()
  File "/usr/lib64/python2.7/ensurepip/__init__.py", line 248, in _main
    default_pip=args.default_pip,
  File "/usr/lib64/python2.7/ensurepip/__init__.py", line 110, in bootstrap
    new_whl = rewheel.rewheel_from_record(dr, rewheel_dir)
  File "/usr/lib64/python2.7/ensurepip/rewheel/__init__.py", line 75, in rewheel_from_record
    to_write, to_omit = get_records_to_pack(site_dir, record_relpath)
TypeError: 'NoneType' object is not iterable

Comment 1 Charalampos Stratakis 2016-09-01 08:05:49 UTC
I guess the downstream patch needs to be rebased to include these lines as well. Will take a look at that.

Comment 2 Charalampos Stratakis 2016-09-01 09:33:26 UTC
You are right in that. I will push new builds today.

Comment 3 Fedora Update System 2016-09-01 16:09:21 UTC
python-2.7.12-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-91eaf87cdb

Comment 4 Fedora Update System 2016-09-01 16:09:54 UTC
python-2.7.12-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a7f22bb34

Comment 5 Fedora Update System 2016-09-01 16:49:20 UTC
python-2.7.11-9.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1a2718a110

Comment 6 Fedora Update System 2016-09-03 03:24:19 UTC
python-2.7.12-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a7f22bb34

Comment 7 Fedora Update System 2016-09-03 03:53:30 UTC
python-2.7.11-9.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1a2718a110

Comment 8 Fedora Update System 2016-09-03 03:54:36 UTC
python-2.7.12-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-91eaf87cdb

Comment 9 Fedora Update System 2016-09-03 08:26:08 UTC
python-2.7.12-6.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1791da4add

Comment 10 Fedora Update System 2016-09-03 08:27:21 UTC
python-2.7.12-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-57c36febbb

Comment 11 Fedora Update System 2016-09-03 08:27:53 UTC
python-2.7.11-10.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7249986d74

Comment 12 Fedora Update System 2016-09-04 01:19:18 UTC
python-2.7.11-10.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7249986d74

Comment 13 Fedora Update System 2016-09-04 01:21:20 UTC
python-2.7.12-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-57c36febbb

Comment 14 Fedora Update System 2016-09-04 01:23:42 UTC
python-2.7.12-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1791da4add

Comment 15 Charalampos Stratakis 2016-09-05 15:01:48 UTC
*** Bug 1283658 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2016-09-05 22:51:38 UTC
python-2.7.12-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2016-09-06 18:19:38 UTC
python-2.7.12-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-09-09 16:52:32 UTC
python-2.7.11-10.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.