Bug 1372202 - Add Users into User Group editors fails to show Full names
Summary: Add Users into User Group editors fails to show Full names
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Nikhil Dehadrai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-01 07:40 UTC by Jan Pazdziora
Modified: 2017-08-01 09:39 UTC (History)
3 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:39:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Jan Pazdziora 2016-09-01 07:40:40 UTC
Description of problem:

The Identity > User Groups > select group > members Users > Add dialog popup Add Users into User Group editors lists Available users that could be added to the group. The table has first column with checkboxes, second column titled Full name, and third column titled user login.

The Full name entries are empty for all users, even for those for which Full name is shown in Identity > Users > select user > Settings.

Selecting the user and moving them to Prospective side of the dialog does not help -- the Full name colum is empty there as well.

Version-Release number of selected component (if applicable):

ipa-server-4.4.0-8.el7

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have IPA server.
2. Create user bob with first name Robert, last name Chase.
3. Go to user group list, select group editors, click Add to add user.

Actual results:

User bob's full name is not shown.

Expected results:

User bob's full name is shown.

Additional info:

Comment 2 Petr Vobornik 2016-09-05 16:42:46 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6055

Comment 3 Petr Vobornik 2016-09-05 16:44:05 UTC
Was addressed upstream by removing the column given that Web UI doesn't get the info from simple user-find call.

master:
    ffea8218c7d6db3abe4667a4d05817249a0e83bd Remove full name from adding user to user group dialog

Comment 5 Nikhil Dehadrai 2017-06-02 10:20:08 UTC
Created attachment 1284373 [details]
User-Added-to-group

User-Added-to-group

Comment 6 Nikhil Dehadrai 2017-06-02 10:21:13 UTC
Created attachment 1284374 [details]
Groups-Add-Button

Groups-Add-Button

Comment 9 Nikhil Dehadrai 2017-06-02 13:51:17 UTC
Ipa-server: ipa-server-4.5.0-13.el7.x86_64

Verified that with latest version of IPA server on accessing 

1. "Identity > Groups > User Groups > select group (editors in my case) > members Users list is displayed and "Full name" column is not present and only login column is displayed.
2. "Identity > Groups > User Groups > select group (editors in my case) > Add: dialog popup for Add Users does not contain "Full name" column and only login column is displayed.

Refer attached Screenshot in Comment#5 and Comment#6.

Thus on the basis of above observations, marking status of bug to "VERIFIED"

Comment 10 errata-xmlrpc 2017-08-01 09:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.