Bug 137235 - [RHAS 2.1] usb keyboard doesn't work in grub
[RHAS 2.1] usb keyboard doesn't work in grub
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: grub (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-26 16:55 EDT by john stultz
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 16:58:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john stultz 2004-10-26 16:55:35 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
Using an IBM x445 w/ RSA2, after installing RHAS 2.1 (this problem 
has been seen w/ U4, U5, and U6 beta), grub does not respond to the 
USB keyboard.  
 
This looks to be the same issue as the RH7.2 bug #64684 
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=64684 
 
Using the grub 0.93 packages linked from that bug resolved this 
issue. This issue is also not seen w/ RHEL3.0 
 
 
Version-Release number of selected component (if applicable): 
grub-0.90-11 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Install RHAS 2.1 on x445 w/ RSA2 using only USB keyboard 
2. Wait for grub menu 
3. Try pressing keyboard to select alternate kernel 
     
 
Actual Results:  No response to keyboard input 
 
Expected Results:  Grub responds to keyboard input 
 
Additional info: 
 
This does not seem to affect x445s w/ RSA1
Comment 1 Jeremy Katz 2004-10-26 16:58:05 EDT
Due to the way the grub package works, this can't really have much of
anything done with it in the way of an update as getting the actual
bits for the boot sector installed automatically on an upgrade is
essentially impossible.

Also, the risk of regressions on hardware which has worked thus far is
too great for changing something as critical as the boot loader this
late in the life of RHEL 2.1.
Comment 2 john stultz 2004-10-26 17:14:24 EDT
Not sure I followed that first bit. How is it impossible to upgrade 
grub? Installing the grub 0.93 packages (I believe they're rh7.2 
packages) does seem to fix the problem.  
 
I could understand the hesitancy to change anything so late, but this 
is affecting a customer, so might you reconsider? Should I open an 
issue tracker entry instead? 

Note You need to log in before you can comment on or make changes to this bug.