Bug 1372385 - @host.operatingsystem.password_hash should work with safe mode enabled
Summary: @host.operatingsystem.password_hash should work with safe mode enabled
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning Templates
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Katello QA List
URL:
Whiteboard:
: 1403363 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-01 14:36 UTC by Sean O'Keeffe
Modified: 2019-09-26 14:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-20 16:21:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 16416 None None None 2016-10-03 16:38:45 UTC
Foreman Issue Tracker 18508 None None None 2017-02-15 08:25:44 UTC

Description Sean O'Keeffe 2016-09-01 14:36:43 UTC
Description of problem:
@host.operatingsystem.password_hash should work with safe mode enabled


Version-Release number of selected component (if applicable):
foreman 1-10

How reproducible:
100%

Steps to Reproduce:
1. try using @host.operatingsystem.password_hash in a KS template with safe_mode render set to true
2.
3.

Actual results:
KS render error


Expected results:
KS to render

Additional info:

Comment 2 Bryan Kearney 2016-10-03 16:38:44 UTC
Connecting redmine issue http://projects.theforeman.org/issues/16416 from this bug

Comment 5 Marek Hulan 2017-02-15 08:29:36 UTC
*** Bug 1403363 has been marked as a duplicate of this bug. ***

Comment 6 Marek Hulan 2017-02-15 08:32:31 UTC
The template shipped with Katello was not updated to load the hash algorithm from OS, only templates coming in Foreman core were. I sent a patch that should make this complete.

Comment 7 pm-sat@redhat.com 2017-02-15 09:19:41 UTC
Upstream bug assigned to mhulan@redhat.com

Comment 8 pm-sat@redhat.com 2017-02-15 09:19:45 UTC
Upstream bug assigned to mhulan@redhat.com

Comment 9 Bryan Kearney 2017-03-20 16:21:18 UTC
This bug has an upstream issue. When this issue is resolved, it will be included in the next Satellite release. We will no longer be tracking this downstream. If you feel this should not have been closed, please feel free to re-open with additional details.


Note You need to log in before you can comment on or make changes to this bug.