Bug 1372458 - persistent volume claim stuck in pending
Summary: persistent volume claim stuck in pending
Keywords:
Status: CLOSED DUPLICATE of bug 1370312
Alias: None
Product: OKD
Classification: Red Hat
Component: Storage
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Bradley Childs
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks: OSOPS_V3
TreeView+ depends on / blocked
 
Reported: 2016-09-01 18:57 UTC by Max Whittingham
Modified: 2016-09-26 14:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-06 14:49:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Max Whittingham 2016-09-01 18:57:16 UTC
Description of problem: 
New pod deployed created a claim on an existing pv, even though the claim correctly bound to the pv as seen by 'oc get pv' the pv did not attach to the instance as seen in AWS as the volume is still listed as 'Available' and unattached to the node.


Version-Release number of selected component (if applicable):
OpenShift 3.2.1.7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
pvc still in pending, not correctly attached to the node. Volume is still marked as Available and not attached to the instance in aws.

Expected results:
pvc claim to correctly attach to the instance, pvc should not be in pending.

Additional info:
[root]# oc get pvc -n jrawlings
NAME            STATUS    VOLUME          CAPACITY   ACCESSMODES   AGE
nexus-storage   Pending   nexus-storage   0                        3h

[root]# oc get pvc nexus-storage -o yaml -n jrawlings
apiVersion: v1
kind: PersistentVolumeClaim
metadata:
  creationTimestamp: 2016-09-01T14:03:41Z
  labels:
    group: io.fabric8.devops.apps
    project: nexus
    provider: fabric8
    version: 2.2-SNAPSHOT
  name: nexus-storage
  namespace: jrawlings
  resourceVersion: "14700258"
  selfLink: /api/v1/namespaces/jrawlings/persistentvolumeclaims/nexus-storage
  uid: e363650f-704c-11e6-abe4-0e4452489d53
spec:
  accessModes:
  - ReadWriteOnce
  resources:
    requests:
      storage: 100Mi
  volumeName: nexus-storage
status:
  phase: Pending


[root]# oc get pv pv-1-rh-idev-master-46a1e-vol-fe696d5b -o yaml
apiVersion: v1
kind: PersistentVolume
metadata:
  creationTimestamp: 2016-06-17T13:47:03Z
  labels:
    type: ebs
  name: pv-1-rh-idev-master-46a1e-vol-fe696d5b
  resourceVersion: "14700260"
  selfLink: /api/v1/persistentvolumes/pv-1-rh-idev-master-46a1e-vol-fe696d5b
  uid: f8ffe396-3491-11e6-8ccb-0e6aaf341bbf
spec:
  accessModes:
  - ReadWriteOnce
  awsElasticBlockStore:
    fsType: ext4
    volumeID: aws://us-east-1c/vol-fe696d5b
  capacity:
    storage: 1Gi
  claimRef:
    apiVersion: v1
    kind: PersistentVolumeClaim
    name: nexus-storage
    namespace: jrawlings
    resourceVersion: "14700258"
    uid: e363650f-704c-11e6-abe4-0e4452489d53
  persistentVolumeReclaimPolicy: Retain
status:
  phase: Bound

Comment 1 Eric Paris 2016-09-02 12:41:39 UTC
Attaching the node logs would be very helpful.

Comment 2 Jan Safranek 2016-09-02 12:49:15 UTC
This looks very similar to #1369977

OpenShift master logs (with log level 5) from master start to would be very helpful indeed!

I also need some steps to reproduce - what did you do? What is PV pv-1-rh-idev-master-46a1e-vol-fe696d5b and PV nexus-storage? How did you create the PVC (i.e. the input yaml)? Did nexus-storage or pv-1-rh-* exist at that moment?

Comment 3 Max Whittingham 2016-09-02 16:35:58 UTC
I believe that nexus-storage is the name of the pvc to claim the pv pv-1-rh-idev-master-46a1e-vol-fe696d5b

oc describe pv pv-1-rh-idev-master-46a1e-vol-fe696d5b
Name:		pv-1-rh-idev-master-46a1e-vol-fe696d5b
Labels:		type=ebs
Status:		Bound
Claim:		jrawlings/nexus-storage
Reclaim Policy:	Retain
Access Modes:	RWO
Capacity:	1Gi
Message:	
Source:
    Type:	AWSElasticBlockStore (a Persistent Disk resource in AWS)
    VolumeID:	aws://us-east-1c/vol-fe696d5b
    FSType:	ext4
    Partition:	0
    ReadOnly:	false

Based on the timestamp of creation, the pv was created before the pvc.

Comment 4 Jan Safranek 2016-09-05 07:45:01 UTC
interesting, from pvc yaml I can read nexus-storage PVC is bound to nexus-storage PV:

kind: PersistentVolumeClaim
metadata:
  name: nexus-storage
spec:
  volumeName: nexus-storage


Was there any nexus-storage PV?

Comment 5 Max Whittingham 2016-09-06 14:49:30 UTC

*** This bug has been marked as a duplicate of bug 1370312 ***


Note You need to log in before you can comment on or make changes to this bug.