Bug 1372508 - Gnocchi is default backend but not running out of the box.
Summary: Gnocchi is default backend but not running out of the box.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 10.0 (Newton)
Assignee: Pradeep Kilambi
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-02 00:36 UTC by Alex Krzos
Modified: 2016-12-14 15:55 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160907212643.90c852e.2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:55:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Alex Krzos 2016-09-02 00:36:24 UTC
Description of problem:
Deployed OSP10 by OSPd 10 and Gnocchi is configured as a backend by default, but is not operational out of the box.  To get gnocchi fully running.  I had to start gnocchi-metricd and gnocchi-statsd services on all controllers and run: "gnocchi-upgrade --create-legacy-resource-types" on one controller.  The Gnocchi api services which runs as a child process to httpd is up and running.  If gnocchi is configured as a default backend shouldn't it be running out of the box.


Version-Release number of selected component (if applicable):
RHOP 10 Newton
2016-08-30.1 build of OSP10


How reproducible:
Always

Steps to Reproduce:
1.Deploy brand new overcloud
2.Check if gnocchi is configured as backend:
[root@overcloud-controller-0 ~]# grep meter_dispatchers=/etc/ceilometer/ceilometer.conf 
meter_dispatchers=gnocchi
3. Check is metricd/statsd services are running:
[root@overcloud-controller-0 ~]# ps afx | egrep -i "[Gg]nocchi-metricd|[Gg]nocchi-statsd" -c
0


Actual results:
Gnocchi services are not up and running and require some further configuration.

Expected results:


Additional info:

Ironically enough, previously in OSP9, gnocchi was not the default backend but was found running by default. - https://bugzilla.redhat.com/show_bug.cgi?id=1351780

Comment 6 errata-xmlrpc 2016-12-14 15:55:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.