Bug 137256 - unresolvable (cyclical) error in gfs-fsck
Summary: unresolvable (cyclical) error in gfs-fsck
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: AJ Lewis
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-26 22:57 UTC by Erling Nygaard
Modified: 2010-01-12 03:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 16:58:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file containing a file system that has block conflicts (83.69 KB, application/octet-stream)
2004-10-28 19:18 UTC, Jonathan Earl Brassow
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:659 normal SHIPPED_LIVE Updated GFS packages 2004-12-03 05:00:00 UTC

Description Erling Nygaard 2004-10-26 22:57:33 UTC
Description of problem:
looping fsck giving a "unresolvable (cyclical) error"

Version-Release number of selected component (if applicable):
GFS 5.2.1 on RHEL3

How reproducible:
unknown

Steps to Reproduce:
1. mount gfs and run stuff
2. reboot storage device that contains GFS filesystem
3. run gfs_fsck
  
Actual results:
looping fsck

Expected results:
fsck fixing problems and exiting normally

Additional info:
Ask Erling for 594M logfile containing output from fsck

Comment 1 Jonathan Earl Brassow 2004-10-28 19:14:36 UTC
The problem was that two inodes were pointing to the same data and
both inodes existed and were linked to from a directory.

One inode would get removed, but later, because it was detected in the
FTW, it would be readded.  When the fsck was restarted, it would
happen again.

Now, when I remove the inode, I destroy the meta header as well, so
that it is considered invalid during the FTW and does not get readded.

Comment 2 Jonathan Earl Brassow 2004-10-28 19:18:44 UTC
Created attachment 105909 [details]
file containing a file system that has block conflicts

Steps to test:
1. uncompress attachment
2 [details]. run fsck on it
3. mount the file 'mount -t gfs <file> <location> -o loop

Comment 3 Jonathan Earl Brassow 2004-10-28 19:31:38 UTC
Fixed in 5.2.1, 6.0, and 6.1

Comment 4 Tim Powers 2004-12-03 16:58:45 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-659.html



Note You need to log in before you can comment on or make changes to this bug.