Bug 1372584 - Fix the test case http://review.gluster.org/#/c/15385/
Summary: Fix the test case http://review.gluster.org/#/c/15385/
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Poornima G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1372586
TreeView+ depends on / blocked
 
Reported: 2016-09-02 06:54 UTC by Poornima G
Modified: 2017-03-06 17:24 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1372586 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:24:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Poornima G 2016-09-02 06:54:31 UTC
Description of problem:
Currently md-cache invalidation feature is enabled by setting "performance.cache-invalidation", but this case was sent when "features.cache-invalidation" was enabling md-cache invalidation. Hence, fix the same.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2016-09-02 06:55:40 UTC
REVIEW: http://review.gluster.org/15385 (tests: Fix one of the upcall patches) posted (#2) for review on master by Poornima G (pgurusid@redhat.com)

Comment 2 Worker Ant 2016-09-02 06:56:46 UTC
REVIEW: http://review.gluster.org/15385 (tests: Fix one of the upcall tests) posted (#3) for review on master by Poornima G (pgurusid@redhat.com)

Comment 3 Worker Ant 2016-09-02 13:02:27 UTC
COMMIT: http://review.gluster.org/15385 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit 6459fc812219551291e4be426ed8ecf2c90813a4
Author: Poornima G <pgurusid@redhat.com>
Date:   Fri Sep 2 10:47:13 2016 +0530

    tests: Fix one of the upcall tests
    
    Currently md-cache invalidation feature is enabled by setting
    "performance.cache-invalidation", but this case was sent when
    "features.cache-invalidation" was enabling md-cache invalidation.
    Hence, fix the same.
    
    Change-Id: If044f6208179748a120fbe1d63b676367e707f73
    BUG: 1372584
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/15385
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Shyamsundar 2017-03-06 17:24:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.