Bug 137263 - Prism54 fails to upload firmware only on boot
Prism54 fails to upload firmware only on boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-10-26 21:23 EDT by Neil Gierman
Modified: 2014-03-16 22:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: 7.93.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 00:45:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump of dmesg (12.37 KB, text/plain)
2004-10-26 21:25 EDT, Neil Gierman
no flags Details
/var/log/messages (101.20 KB, text/plain)
2004-10-27 08:03 EDT, Neil Gierman
no flags Details

  None (edit)
Description Neil Gierman 2004-10-26 21:23:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Since upgrading from FC2 to FC3test3 my Netgear WG11 (Prism54) will
not load automatically on boot. dmesg shows the failure was "failed to
upload firmware". Simply rmmod'ing and modprobing prism54 after
hotplug and pcmcia are up will load the firmware fine and the card is
active (I have since added rmmod prism54;modprobe prism54 to my
rc.local and "band-aid's the priblem). Another bug (113462) on RH9 was
open but is now listed as closed with the resolution of Rawhide, and
my comment about FC3test3 was refered to a bug in udev that was
supposed to be fixed. As of 039-6, I still have the same symptoms.
Others on fedora-test-list have commented about the same bug/symptom.

Version-Release number of selected component (if applicable):
udev-039-6

How reproducible:
Always

Steps to Reproduce:
1. Boot machine with prism54 card inserted
2.
3.
    

Actual Results:  lights on card are not active, dmesg shows failure
uploading firmware, eth1 not a device

Expected Results:  green light on card solid, amber light flashing
with activity, no errors in dmesg, eth1 up

Additional info:

dmesg dump attached
Comment 1 Neil Gierman 2004-10-26 21:25:25 EDT
Created attachment 105821 [details]
dump of dmesg

dmesg dump _including_ removal and reinsertion of prism54 at the end.
Comment 2 Bill Nottingham 2004-10-27 00:18:22 EDT
a) where is your firmware file located
b) can you attach your /var/log/messages instead? It will be somewhat
more accurate than just dmesg
Comment 3 Harald Hoyer 2004-10-27 04:38:57 EDT
FYI the location for firmwares changed to /lib/firmware...
Comment 4 Harald Hoyer 2004-10-27 04:59:46 EDT
isn't that the bug, that hotplug is disabled in ifup??
Comment 5 Harald Hoyer 2004-10-27 05:01:34 EDT
comment from the mailing list:

Would you mind if I added a comment to your bug? I what I would as is
regarding the following snippet of
/etc/rc.d/init.d/network (lines 87-90)
    oldhotplug=`sysctl kernel.hotplug  2>/dev/null | \
        awk '{ print $3 }' 2>/dev/null`
    sysctl -w kernel.hotplug="/bin/true" > /dev/null 2>&1
which is where hotplugging is specifically disabled, making the
loading of the firmware impossible.
That can be demonstrated by commenting out (#) the sysctl -w ... line
and rebooting.
Does using udev negate the comment #2 in the #113462 about
unilaterally "enabling" hotplug?

Also lines (182-186) from
/etc/sysconfig/network-scripts/network-functions in is_available()
    HOTPLUG=`cat /proc/sys/kernel/hotplug`
    echo "/etc/hotplug/firmware.agent" > /proc/sys/kernel/hotplug
    modprobe $1 > /dev/null 2>&1 || {
      echo "$HOTPLUG" > /proc/sys/kernel/hotplug
      return 1
don't seem to help.
Comment 6 Neil Gierman 2004-10-27 08:00:51 EDT
firmware is located in /lib/firmware. According to
/etc/hotplug/firmware.agent, that is the correct place (it does load
the firmware correctly at the end of the boot cycle, just not durring
boot).

/var/log/messages attached.
Comment 7 Neil Gierman 2004-10-27 08:03:47 EDT
Created attachment 105832 [details]
/var/log/messages

includes a few reboots.
Comment 8 Neil Gierman 2004-10-29 09:02:31 EDT
Just upgraded to initscripts-7.93.2-1 that was added to yum last 
night and still same symptoms.
Comment 9 Bill Nottingham 2004-11-03 23:39:21 EST
Hm, I can't reproduce it on a prism54 card here; it does not load it
on bootup, but that's because the device isn't automatically brought
up. When the interface is opened, it loads fine. Will run some more tests.
Comment 10 Bill Nottingham 2004-11-04 00:45:59 EST
Oops, found it.

Fixed in 7.93.5-1.

Note You need to log in before you can comment on or make changes to this bug.