Bug 1372779 - another typo in "Proxy connnection failed, please check your settings."
Summary: another typo in "Proxy connnection failed, please check your settings."
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-02 15:52 UTC by John Sefler
Modified: 2017-08-01 19:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:20:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1496 None None None 2016-09-20 20:09:52 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description John Sefler 2016-09-02 15:52:42 UTC
Description of problem:
This typo was already fixed for the CLI in bug 1335537
This typo was also found for the GUI


Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.17.12-1.el7.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel7 ~]# rpm -ql subscription-manager-gui | egrep managergui.py$
/usr/lib/python2.7/site-packages/subscription_manager/gui/managergui.py
[root@jsefler-rhel7 ~]# grep "Proxy conn" /usr/lib/python2.7/site-packages/subscription_manager/gui/managergui.py
            system_exit(os.EX_UNAVAILABLE, _("Proxy connnection failed, please check your settings."))


Actual results:
  "Proxy connnection failed, please check your settings."
         ^^^^^^^^^^^
           typo


Expected results:
  "Proxy connection failed, please check your settings."


Additional info:
  Good news: since both typo and non-typo exist in the translation keys, a fix for this does not require new translations.
 [root@jsefler-rhel7 ~]# msgunfmt --no-wrap /usr/share/locale/it/LC_MESSAGES/rhsm.mo | egrep "Proxy .*, please check your settings"
msgid "Proxy connection failed, please check your settings."
msgid "Proxy connnection failed, please check your settings."

Comment 3 Shwetha Kallesh 2017-04-05 09:12:36 UTC
There is no typo now , so moving bug to verified state

[root@dhcp70-149 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.5-1.el7
python-rhsm: 1.19.3-1.el7

[root@dhcp70-149 ~]# rpm -ql subscription-manager-gui | egrep managergui.py$
/usr/lib/python2.7/site-packages/subscription_manager/gui/managergui.py

[root@dhcp70-149 ~]# grep "Proxy conn" /usr/lib/python2.7/site-packages/subscription_manager/gui/managergui.py
            print_error(_("Proxy connection failed, please check your settings."))
            error_dialog = messageWindow.ContinueDialog(_("Proxy connection failed, please check your settings."),


[root@dhcp70-149 ~]# msgunfmt --no-wrap /usr/share/locale/it/LC_MESSAGES/rhsm.mo | egrep "Proxy .*, please check your settings"
msgid "Proxy connection failed, please check your settings."

Comment 4 errata-xmlrpc 2017-08-01 19:20:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.