Bug 1372784 - [Backwards Compatibility] OSP10 undercloud does not contain older THT for backwards compatibility
Summary: [Backwards Compatibility] OSP10 undercloud does not contain older THT for bac...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates-compat
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Mike Burns
QA Contact: Dan Yasny
URL:
Whiteboard:
Depends On: 1376215
Blocks: 1337798
TreeView+ depends on / blocked
 
Reported: 2016-09-02 16:33 UTC by Dan Yasny
Modified: 2016-12-14 15:56 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-compat-2.0.0-34.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:56:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
RDO 2330 None None None 2016-09-14 23:46:38 UTC
RDO 2427 None None None 2016-09-16 22:36:09 UTC

Description Dan Yasny 2016-09-02 16:33:54 UTC
Description of problem:
/usr/share/openstack-tripleo-heat-templates in OSP8 and 9 contains THT directories used for older versions deployment and maintenance. In OSP10 there is no "mitaka" or "liberty" directory there at all

Version-Release number of selected component (if applicable):
openstack-tripleo-puppet-elements-5.0.0-0.20160809165922.703eeea.el7ost.noarch
openstack-tripleo-heat-templates-5.0.0-0.20160823140311.72404b.1.el7ost.noarch
puppet-tripleo-5.0.0-0.20160823145616.c16ae9c.el7ost.noarch
openstack-tripleo-image-elements-5.0.0-0.20160810171527.98b9c6a.el7ost.noarch
openstack-tripleo-common-5.0.0-0.20160823132420.be5b0d3.el7ost.noarch
python-tripleoclient-5.0.0-0.20160823121648.2a9a168.el7ost.noarch


How reproducible:
always

Steps to Reproduce:
1. deploy OSP10 UC
2. look for older version THTs

This is blocking all testing for OSP10 backwards compatibility

Comment 2 Mike Burns 2016-09-19 17:47:18 UTC
Note:  you will need to manually install openstack-tripleo-heat-templates-compat.  There is no dependency in the original THT package pulling this in by default.

Comment 4 Dan Yasny 2016-10-05 19:00:22 UTC
Checked and confirmed on two subsequent versions, setting to VERIFIED

Comment 8 errata-xmlrpc 2016-12-14 15:56:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.