Bug 137286 - Please add "hinv" utility
Summary: Please add "hinv" utility
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-27 09:33 UTC by Toralf
Modified: 2015-01-04 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-20 04:47:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The actual script (1.40 KB, text/plain)
2004-10-27 09:34 UTC, Toralf
no flags Details

Description Toralf 2004-10-27 09:33:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
I'm adding this just because I thought I might give you this little
utility I wrote quite a few years ago (with minor updates later.)

It's called "hinv", as in "hardware inventory", and is just a very
simple script, but may still be quite useful. It offers a quick way to
get an overview of the hardware installed on the system - quicker than
inspecting log files or consulting the /proc filesystem directly (or
that's the idea, anyway.) It was inspired by the command of the same
name on SGI systems.

Comment 1 Toralf 2004-10-27 09:34:06 UTC
Created attachment 105830 [details]
The actual script

Comment 2 Dave Jones 2004-11-20 04:47:30 UTC
the value of an 'all in one' script like this vs the long term maintainence
burden doesn't really seem worth it.  Its rare that we need to know everything
about a users system when we get bug reports, usually we can ask for something
specific for which we have existing tools (lspci, x86info etc).


Comment 3 Dave Jones 2004-11-20 04:48:10 UTC
forgot to mention -- you might want to try the fedora-extras folks at fedora.us,
maybe they'll find it an interesting addition.


Note You need to log in before you can comment on or make changes to this bug.